Best answer

Microsoft Dynamics 365 CRM Cannot read property 'find' of undefined

Show first post
This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

84 replies

We are having the exact same issue. Please add me as well

Userlevel 7
Badge +12

Hi everyone

It looks like this is bug that was discovered a couple of days ago. When some users try to connect to Microsoft Dynamics 365, they see the error message Cannot read property 'find' of undefined

@EmmaEmergo, @Yurian and @Carlf, I’m sorry that you’re having this trouble with yourZaps. I’ve added you as affected users on the bug, which lets the team know how many users are having this issue and also means that we’ll send you an email when we have an update. 

Userlevel 1

We are getting the same Error, both when trying to update a Zap and when trying to reconnect to CRM.

Hi, I’m having the same problem, did you find the answer? 

Userlevel 7
Badge +14

Hi @EmmaEmergo 

Best to open a ticket with Zapier Support:

Userlevel 1




Userlevel 1

I get this error when connecting to dynamics, not in a specific zap, however two zaps that i have tried to edit since this problem are now offline and cannot be turned on because of this same error

Userlevel 7
Badge +10


Can you show us screenshots of the error message and how you have this step configured in the zap editor.

Userlevel 1

@Troy Tessalone