Best answer

MS Teams apps - trouble with account connection

  • 23 September 2020
  • 58 replies
  • 2424 views

Userlevel 1

I am having this issue as well for a new MS Team connection.  I cannot load the “Team” despite having the account connection set up WITHIN MS teams and connected back to Zapier. The full error message is:

We’re having trouble loading 'Team' data

An owner must install the Zapier app from the Teams store in your team to use this feature. Then reconnect your Microsoft account in Zapier.

If I go into the MS Team itself it will tell me the Zapier app/bot is installed.

Thanks!

icon

Best answer by nicksimard 31 May 2021, 21:03

View original

58 replies

Userlevel 1

Yes, this worked. I didn’t realise that I had to essentially create a brand new connection on Zapier. Probably the old connection was using the old connection method for Teams and so would not work.

Userlevel 1

I had the same issues, mine were fixed after trying all of above.. PLUS: make sure that you're logging in with an email adress and password (not login with Microsoft).

What solved it for me was:
1. Remove all connections and the app in Teams
2. Go to Zapier => reset your password ​​​​​​
3. Login again to Zapier, but with password (not MS login)
4. Add the app to the team in Teams
5. Create a new Zap and set up the connection from scratch

Then it worked! 

I would say we are having the issue and would like to be notified but this issue was reported nearly a year ago. Clearly it’s not going to get fixed...

Userlevel 7
Badge +11

If you’ve installed the Zapier app but are still seeing Requires Zapier app to be installed next to the Team in the dropdown menu...

Microsoft

Please Read This

The Zapier app must be installed within the Team you want to access in Zapier. Makes sense, but it's much more confusing than it may seem and Microsoft  doesn't necessarily indicate whether this has been done properly. 

NOTE: These instructions were originally compiled in November of 2020, and should be accurate. If you see that things are different than described below please let us know!

What to Check:

  1. Open up Teams and check the Teams tab
  2. Find the Team you'd like to access in Zapier and press the 3 dots next to its name (not General)
  3. Select Manage team. Looks like: 

     

  4. Click Apps > More apps.
  5. You should now see Microsoft's app store and can search for "Zapier."
  6. Click the purple dropdown arrow next to Open and then Add to a team.
  7. From there, [Team Name] > General should be populated by default, but if not, locate it and then click Set up a bot

     

Now you can come back to Zapier and check the Zap again. You may have to refresh and if the Team dropdown menu in the Zap is still giving you that "Requires Zapier app to be Installed" message, you might need to disconnect and reconnect Teams to Zapier from scratch.

Im having the same problem here, despite having deleted the MS Teams app connection, installing Xapier app in Teams, reconnecting Xapier to teams and trying to set the whole thing up from inside Zapier in teams

 

 

Userlevel 7
Badge +9

Thanks for reaching out, @Andrew B! Apologies if this is redundant but to clarify were you able to give the tips chrishill and Nick provided a shot? It sounds like connecting your specific Team has been the fix for most users but as Nick mentioned it isn’t as straight forward as one would hope. Happy to get you added to this report if so but thought it was worth double checking. Thanks!
 

I just got it working over here. This may help some of you.  I had the Zapier App installed for myself but not for my Team.  So I could go to my Zapier App from my app list, partially configure a Zap but never access team data such as a Channel for example. You need to go to the Teams list tab, choose the team where you want to install the Zapier app, click on the 3 dot menu to the right, and then Manage Team, Then go to the Apps tab. Make sure Zapier is there. If it isn’t, install it from that location.  Then make sure you reconnect to Teams account in Zapier (this step is key).

 

If you’ve installed the Zapier app but are still seeing Requires Zapier app to be installed next to the Team in the dropdown menu...

Microsoft

Please Read This

The Zapier app must be installed within the Team you want to access in Zapier. Makes sense, but it's much more confusing than it may seem and Microsoft  doesn't necessarily indicate whether this has been done properly. 

NOTE: These instructions were originally compiled in November of 2020, and should be accurate. If you see that things are different than described below please let us know!

What to Check:

  1. Open up Teams and check the Teams tab
  2. Find the Team you'd like to access in Zapier and press the 3 dots next to its name (not General)
  3. Select Manage team. Looks like: 

     

  4. Click Apps > More apps.
  5. You should now see Microsoft's app store and can search for "Zapier."
  6. Click the purple dropdown arrow next to Open and then Add to a team.
  7. From there, [Team Name] > General should be populated by default, but if not, locate it and then click Set up a bot

     

Now you can come back to Zapier and check the Zap again. You may have to refresh and if the Team dropdown menu in the Zap is still giving you that "Requires Zapier app to be Installed" message, you might need to disconnect and reconnect Teams to Zapier from scratch.

 

Aha that worked!! I had added Zapier to MS Teams. Didn’t realise the slight difference to add it to a channel

FYI It’s a shame you cannot insert links into teams messages (the message should be HTML or plain text). Just a suggestion. 

Userlevel 7
Badge +11

That’s great news, @Andrew B:relaxed:

I see you’ve also commented on a related thread regarding an existing feature request to support HTML/Markdown formatting on chat messages. We’ll get your vote added for that so that once that’s implemented it will be possible to insert links. 

Reply