Best answer

"Couldn't log in with plugin" error in OpenAI GPT when using Zapier AI actions.

  • 11 November 2023
  • 37 replies
  • 2371 views

Userlevel 3

I'm encountering difficulties while attempting to utilize GPTs with AI Actions in Zapier. I've adhered to the provided guidelines and successfully integrated the Zapier action into the GPT. To facilitate a connection to Google Drive using the GPT, I established AI Actions at https://actions.zapier.com/. The AI actions function correctly when tested on Zapier. However, an issue arises when the GPT engages the Zapier action, prompting me to authenticate via Zapier. Despite granting permission during the login process, the browser page refreshes and indicates an inability to connect with the plugin – a plugin that I am not employing. This is the error in Openai: Couldn't log in with plugin. I've ensured all Google permissions are appropriately set. Could you advise on how to resolve this matter?

Thanks for your help

Regards

icon

Best answer by Lucadocet 10 December 2023, 11:37

View original

37 replies

Userlevel 3

@SamB I solved the problem not by using a VPN, but by changing the default language setting in my OpenAI account to en-US. I am Italian, and it was previously set to it-IT.

 

Userlevel 1

I have the same exact problem.

Userlevel 3

Hi @Troy Tessalone, Thank you very much for the help. I tried following the suggestions in the guide, but nothing changed. In the Actions of Zapier's GPT, there are 3 options for the type of authentication. The default settings are with OAuth authentication. In this case, however, I don't know where to find the "client ID" and "Client secret" values to enter. If I don't enter anything, it doesn't work. Then I tried the API connection type by entering my Zapier API key and selecting "Bearer" as the Auth type, but after clicking "Allow" again, I get the error "Couldn't log in with plugin". As a last attempt, I tried setting the authentication type to "None", but here too, no positive result. What would be the correct type of authentication? API or OAuth? If it's OAuth, which is the default for the Zapier action, should I leave the "client ID" and "Client secret" fields empty, or do I need to fill them with values? If so, where do I find them?

Userlevel 2

Have the same issu. enabled connections but can not send emails or create a doc. 

Userlevel 1

Hello everyone,

I've developed a GPT-based system designed to assist with responding to potential customer inquiries. Our process involves collecting information such as names, emails, etc., from customers and then storing this data in a Google Sheet. The system functions seamlessly on my computer and under my account.

However, I've encountered a puzzling issue. When attempting to use this system on a different computer or with a different ChatGPT account, it seems to require the user to have their own Zapier account. This is confusing because the integration and actions are set up under my Zapier account.

Why does the system require each user to have a separate Zapier account, even though they are accessing the GPTs actions set up in my account? Is there a way to configure the system so that others can use it without needing their own Zapier account?

Any insights or suggestions to address this issue would be greatly appreciated.

Thank you!

Userlevel 2

I can confirm that it is now functioning properly for me! To resolve the issue, please log out and then log back into your OpenAI account. Afterward, proceed to run your assistant as usual. If it still appears as it did before, try clicking on the button or link again. This may prompt a new grant request, and once that's done, you should be good to go. The problem was related to a failure in the OAuth process, which resulted in the OpenAI API not responding to calls. 🚀

Userlevel 1

I have the same issue all the time, was looking to create a chatbot for DGME and it just kept on giving me the same error over and over again.

Userlevel 1

​​​​​​I have the same error, and after changing the Locale setting to en-US, then it works. 😅

Userlevel 1

I have been trying to solve it since it was launched.

It seems like Open AI still have some geolocation restrictions in their endpoints that process the requests with actions, I'm located in Brazil for example, so I was always receiving a 500 Internal server error.

The solution I found: VPN.

I've installed a VPN, set the location to US and it started working perfectly.

Let me know if it works for you guys as well.

Userlevel 2

has anyone solved it?

 

Userlevel 1

@SamB I solved the problem not by using a VPN, but by changing the default language setting in my OpenAI account to en-US. I am Italian, and it was previously set to it-IT.

 

That worked!

Thank you!

Userlevel 7
Badge +14

@rudi.ranck 

GPTs are a brand new to OpenAI and to Zapier, so I expect there to be hiccups.

I don’t work for Zapier, so you can try opening a ticket with Zapier Support for possible assistance: https://zapier.com/app/get-help

Userlevel 1

well actions even they are enabled → dont work. GPT can not conect wih gmail send mail or created doc. 

Userlevel 7
Badge +11

Sorry to hear that workaround of using a VPN didn’t do the trick @Lucadocet.

In that case your best bet will be to flag the issue with the team directly, using the form here: https://ai-feedback.zapier.app/contact-nla. They’ll be able to take a closer look into these errors with you and help to resolve them. Please keep us updated on whether they’re able to suggest an alternative workaround or implement a solution! 🙂 

Userlevel 7
Badge +11

Hi @CorazónDeAmor 👋

Sorry to hear that you’re running into this issue as well. Is it that it was previously working when testing in the live demo area here but isn’t working in the GPT now? I wonder if the AI Action has since been disabled perhaps? 

Can you take a look at the actions set up for your GPT here and confirm whether the necessary AI Actions that you’re wanting to use are still enabled?

Look forward to your reply! 

Userlevel 7
Badge +11

Hi there folks! 👋

Really sorry to hear that you’re all running into that same “Couldn't log in with plugin” error. It sounds like this could potentially be a bug so I’d recommend reaching out to the Support team that are specifically handling AI Actions issues. You can reach them via the form here. They’ll be able to investigate this further with y’all and get a bug report opened up as necessary.

Eager to ensure that this gets fixed so if you’re able to get a solution in place with them, please let us know. Hopefully it’ll be resolved soon! 🤞

Userlevel 3

@SamB I’ve already wrote to the form you provided days ago, but I have not received any response yet.

Userlevel 1

yes i ve noticed the same thing has any one solution ?

 

Userlevel 7
Badge +11

That’s fantastic news @Lucadocet! 🎉 Thanks so much for sharing this information with the rest of the Community here, it’s much appreciated! 🤗 

@Phiapsi@MarkoW@rudi.ranck@Patryk@Vic55@C. Schmidt@Demóstenes Quijada and @JohnHubbert12 - if you didn’t have success using a VPN, does changing the default Locale (Alpha) setting in your OpenAI account to en-US get things working?

Userlevel 7
Badge +14

Hi @Lucadocet 

Good question.

This might be worth a try:

 

@rudi.ranck I’ve tried to follow your steps but is still not working for me. 

 

same

Userlevel 1

for me also doesnt work. Well when user who doesnt have zapier and would like that gpt he use send him an email, it also dosesnt work

Userlevel 3

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

@owork138 I’ve tried to follow all your suggestions but it doesn’t work. Google drive authorizations are correctly set as you can check from the attached screeshot. Regarding the OAuth authentication configuration page for the GPT, in the 'Client ID' and 'Client Secret' fields, should I input specific values or leave them blank? I continue to encounter the same issue when I don't enter any data. If it is necessary to input information, could you please guide me on where to find these details? Thank you for your assistance.

 

 

Userlevel 7
Badge +11

YAY! Glad it worked for you too, @Martin Blaha! 😁🎉 

Same here...tried everything mentioned above, from simple logout/login to checking GDrive…

 

Reply