Best answer

Can't find slack channel in the Pick a Channel dropdown

  • 12 October 2022
  • 30 replies

Userlevel 1

I’m creating a Zap that posts to a slack channel, i’ve connected a Slack account, but when searching for the channel I can see many channels, but not the specific channel I’m looking for. 
Is there anything I need to do in order for a Slack channel to appear in the dropdown?


Best answer by Danvers 18 October 2022, 18:24

View original

30 replies

Userlevel 1

I’m also having this issue, can’t find the right slack channel either by searching the channel name or inputting the Channel ID.


Userlevel 1

Solved it by using Custom ID like @Troy Tessalone suggested. Thanks!

Userlevel 1

Clicking the Load more ~20 times worked!! 😅

I’d suggest for completeness sake though to post how this can be done using the channel ID, because I tried the custom tab and couldn’t really figure out how to make it work. 
It looks like it only lets you choose the ID from the action variables. Just putting in the ID didn’t let me click the confirm button

@Airi Thanks for updating! 

Userlevel 1

Hi, I’m having this exact problem but using the channel ID doesn’t work either. 

Userlevel 1

Hello, I am having the same problem since Friday.

  • I tried loading 20 times until Zapier doesn’t let me anymore
  • I tried with the channel name and the channel id
  • I tried with custom value but it doesn’t apply to my zap, since I need one channel which is not connected to the previous steps of the zap

    Any other ideas on how to solve this?
Userlevel 1

Thanks @Troy Tessalone , I have access to the channel (it’s a public channel), and have also tried using it’s ID in the search, and still nothing…

I also tried adding the Zapier slack app to the channel.

Userlevel 7
Badge +12

Hi folks!

Here are a couple of tips if you’re running into this issue….

As other members have mentioned, you can keep clicking Load more on the Channel dropdown to load more channels. This is because the dropdown can only load a certain number of channels at any one time. 


If that doesn’t work, or you have lots of channels and don’t want to click the Load more button over and over again (understandably!) you can use the Channel ID as a custom value. To find the channel ID, right click the name of the channel in Slack and select View channel details

That will open a window with the channel details and the channel ID is at the very bottom of that window:


Copy the channel ID and open the Zap editor. In the Create Message action, click on the channel field and select Custom. Then paste the ID into the Channel field - make sure that it’s in the Channel field (as shown below) and not in the search box, as that wont work. 



Once you add the text of your message, you’ll be able to finish setting up the step. 


If you’ve gone through these steps and are still having trouble, please get in touch with the Support Team using the Get Help form as they’ll be able to take a look at your Zap with you to get to the bottom of things. 



Userlevel 7
Badge +14


Please post screenshots with how your Slack step is configured in order for us to have proper context.

Userlevel 7
Badge +14


Try using the Custom option to input a static Slack Channel ID value.


@HoneyBook Zaps  



Hello, I was able to solve,

I write  channel name in Search section, and  click many times  [ Lead more ]  button 😂 . ( about 20times…. )


please let’s try.


thank you





I had similar issues to @Oda and @trabajar. I tried all the suggestions (hitting load more and entering the channel ID) and none of it worked. 

I reached out to support and they confirmed that it’s a known bug (bug report has been open since 2020). So I doubt this is going to get resolved anytime soon. 

For what it’s worth, this is only affecting certain private slack channels. Public channels all seem to be searchable. I only say certain private channels because I was able to find other private channels I belonged to just not the one I wanted. I also created a public channel, verified that I could find it, then converted it to a private channel and I could no longer find it anymore.

My workaround is going to be migrating my team to a public channel. 

The Slack ID worked for me, but make sure to be a member of the channel you are looking for

Userlevel 1

Alright, so I’m trying to set up zap between slack and linear. The problem is that the slack channel dropdown doesn’t populate with several of the channels that should be available. I want it to populate with #shop-platform-recipes-content-editor (channel ID C04424H08BC), but it doesnt. The same goes for #shop-platform-recipes-fin (channel ID C03A3Q6KDPH). The last mentioned channel has been used in a similiar zap previously but has now dissapeared from the channel dropdown even though the similar zap is still running.


Userlevel 1


Userlevel 7
Badge +14


Since you know the Slack Channel IDs, you can use the ‘Custom’ option to set a static Channel ID value.



Userlevel 7
Badge +14


Please post screenshots with how your Slack step is configured in order for us to have context, thanks.

I have the same problem, I don’t even have the option to select Custom. Some channels just don’t seem to be findable? Trying to connect Zoom with Slack. 

Userlevel 7
Badge +14

Hi @HoneyBook Zaps 

Good question.

Make sure you have access to the Slack Channel.

You can try inputting the static value for the Slack Channel ID.

You can find the Slack Channel ID by right clicking on the Slack Channel in the left rail, then go to Copy.


Userlevel 6
Badge +3

Hi @JJSH @larst 


I’ve added you both on the list of affected users and we’ll notify you via email once an update is available. Thanks.

I'm having the same problem. Also, there is no ability to type the ID in the custom field because the field doesn't show up. 

Userlevel 7
Badge +14

Hi @trabajar 

Example of a static Slack Channel ID in the Channel field using the CUSTOM option.


Userlevel 7
Badge +14

Hi @MattZap 

Good question and thanks for sharing.

Yes this is a known issue and the workaround you figured out is documented in this related topic:


Userlevel 7
Badge +9

Hey there, @MattZap! Thanks so much for flagging this and sharing your workaround! We appreciate you taking that extra step. 

How recently were you experiencing this? The reason I ask is this is related to a known Slack bug however it appears to have been closed about 5 days ago.

If you’re still running into this could you please open a ticket and reference this thread? It could be worth digging into this a bit more! 

I hope you don’t mind I’m also going to merge this into the thread Troy referenced to keep everything together. 😊

Userlevel 7
Badge +9

Hey there, @trabajar and @Oda!

Were you able to find the channel in the dropdown using the ID as @Troy Tessalone shared?

To be clear, you’ll need to type the ID here. 

If you’re still not able to find the correct channel, would you mind opening a ticket with my teammates in support and link back to this thread?
This is related to a known Slack bug that was closed 5 days ago but if you’re still running into this we definitely want to dig into it further!

I wanted to follow up on this old post, which is now locked.


I experienced the same problem, and it seems like it might be a UI bug.  No matter what I did, I could not get private Slack channels to populate in the dropdown menu.  When I clicked Custom, the screen showed options to add Zendesk fields (Zendesk is the trigger app), which makes no sense in the context of a Slack channel selector.  I recreated the Zap from scratch and got the same behavior.  It seems that clicking the Custom heading causes the wrong section to appear in the UI.  I think the options I’m seeing are ones that belong to the next step, which is Message Text.


Once I realized that the UI was broken, I tried typing the channel name directly into the dropdown field while the incorrect custom section was revealed.  While I could not see any channel names populating, something was working behind the scenes, because I was able to move forward with the Zap.  I confirmed that the correct private Slack channel is indeed connected and is working.


Looks like this is a UI bug, but directly typing in the Slack channel name can be used as a workaround.