Best answer

AWS RDS (Mysql) problem connection

  • 14 December 2020
  • 30 replies
  • 1043 views

Userlevel 1

I'm trying connect de MYSQL plugin (zapier) in my RDS Database (aws), but zapier return a error message: "authentication failed: Could not connect with **** and provided password. The response we got from the server is included below for debugging purposes. 255"

 

I cant find a solution for this error code.

My user, host and password are correct. And the IP 54.86.9.50/32 are enabled in my Security Group. In other integration products, the plugin works.

icon

Best answer by Danvers 18 December 2020, 14:33

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

30 replies

Userlevel 7
Badge +9

Hi there, @FrozenDessertSupplies! Thanks for reaching out.

I’ve got your vote added to that feature request. We’ll be in touch via email with any updates if and when this gets implemented. 🙂

@SamB Please add me to that list as well!

Userlevel 7
Badge +11

Hey @yvonne!

I’ve just double-checked and it’s not been sorted yet, unfortunately. I’ve added you to the list of affected users. We still don’t have an ETA on when this will be resolved but will email you and update the thread here once it is.

Hi there,

 

is this connection problem solved?

I tried connect our MYSQL Database with Zapier. but it’s not working. (error code 255)

our MYSQL version upper then 8.0

Should I added list something?

Or someone can check this for me?

Userlevel 7
Badge +11

Hey @joomify,

I’m afraid I don’t have the full details of how to set up the proxy, as I didn’t set it up myself. The workaround I shared above was passed onto us from a customer that was able to get it working. I did some digging on the mySQL website and was able to find the following guide on setting up proxy users: MySQL 8.0 Reference Manual > Proxy Users 


I’m not sure if that’s the same method that was used for creating the proxy but hopefully that guide is helpful. :) 

@SamB could you share some more details on how you set that proxy up and revamped the queries after login? I’d love to do that myself but have never done it before.

Userlevel 7
Badge +11

Welcome to the Community, @one2ones_dev


I’ve added you to the list of affected users. We’ll be in touch by email as soon as it’s resolved.


I don’t have an update on when this will be added but in the meantime, there is a workaround a user shared with us that you may find useful:
 

"We've set up a workaround for the integration using an SQL proxy, so this issue no longer has the highest priority. It would still help a lot if it were resolved so we can ditch the proxy again.

Our database is configured with "defaultauthenticationplugin=mysqlnativepassword" to ensure backward compatibility, so the connection issue cannot be caused by the authentication protocol itself. I suspect it is caused by the queries it performs after login (it selects @@txisolation which has been removed in MySQL 8.0). Remapping it via our proxy did the trick"


Please do let us know if that helps! :)

Has there been an update on this feature?We need this as well. 

Userlevel 7
Badge +8

@dleight sorry you are running into this- you have been added to the list. I don’t see an ETA at the moment but you will be notified of any updates via email!

Userlevel 1

@Danvers @steph.n please add me to the list, as well. Is there any ETA on this?

The only zaps we are using rely on MySQL connectivity. When we were forced to upgrade a few days ago for security reasons everything stopped working. Now I’m going to have to turn off my plan unless there is some kind of workaround for this.

Userlevel 7
Badge +8

Hi @MyVirtuaLab and @Franck&Sydney - You’ve been added to the report list. Thanks!

@Danvers Please add me to this list as well.  Is this an ETA on this?

add me too please

Userlevel 7
Badge +12

Hi @corey 

I’ve added you to the list of affected users. I don’t have an ETA on when this will be added, I’m sorry about that. 

@Danvers Please add me to this list as well.  Is this an ETA on this?

Userlevel 7
Badge +12

Hi @Siggi!  Thanks for your message, I’ve added you to the feature request as well.

@steph.n please add me to the notification list.

I’m stuck currently and looking at ways to integrate with 8

Userlevel 7
Badge +8

@uCync - You’ve been added!

Userlevel 1

We have the same issue, 

would be great if you add us as well. @Liz_Roberts 

 

Our engine version is: 8.0.20

Userlevel 1

thank you

Userlevel 7
Badge +8

@augustgermar I have added you as well. 

Userlevel 1

Yes please add me to the list as well. support for mysql 8+ is critical to our organization. 

Userlevel 7
Badge +11

Hi @Maaz and @Tiago, from Cloudia.com.br!

I’ve gone and added you to the feature request, so you’ll receive an email notification when this has been implemented.

Guys, this feature is important for us as well. Please, add us to this feature request.

We've been using Zapier for quite a long time. We upgraded our database to MySQL v8.0 and we lost a bunch of our automations performed using ZAPIER.

Does anyone know any workaround?

Hi Danvers,

 

Can you please also add me to the feature request as well. I am also struggling with the same.