Best answer

AWS RDS (Mysql) problem connection

  • 14 December 2020
  • 30 replies

Userlevel 1

I'm trying connect de MYSQL plugin (zapier) in my RDS Database (aws), but zapier return a error message: "authentication failed: Could not connect with **** and provided password. The response we got from the server is included below for debugging purposes. 255"


I cant find a solution for this error code.

My user, host and password are correct. And the IP are enabled in my Security Group. In other integration products, the plugin works.


Best answer by Danvers 18 December 2020, 14:33

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

30 replies

Userlevel 7
Badge +11

Hey @joomify,

I’m afraid I don’t have the full details of how to set up the proxy, as I didn’t set it up myself. The workaround I shared above was passed onto us from a customer that was able to get it working. I did some digging on the mySQL website and was able to find the following guide on setting up proxy users: MySQL 8.0 Reference Manual > Proxy Users 

I’m not sure if that’s the same method that was used for creating the proxy but hopefully that guide is helpful. :) 

Hi there,


is this connection problem solved?

I tried connect our MYSQL Database with Zapier. but it’s not working. (error code 255)

our MYSQL version upper then 8.0

Should I added list something?

Or someone can check this for me?

Userlevel 7
Badge +11

Hey @yvonne!

I’ve just double-checked and it’s not been sorted yet, unfortunately. I’ve added you to the list of affected users. We still don’t have an ETA on when this will be resolved but will email you and update the thread here once it is.

@SamB Please add me to that list as well!

Userlevel 7
Badge +9

Hi there, @FrozenDessertSupplies! Thanks for reaching out.

I’ve got your vote added to that feature request. We’ll be in touch via email with any updates if and when this gets implemented. 🙂