Best answer

Gravity Forms Connection error

  • 11 March 2021
  • 68 replies

Show first post
This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

68 replies

Userlevel 7
Badge +11

Hey @hdav and @Hottest DOg!

I’ve added you both to this bug report so when it gets resolved you’ll be notified via email. I see comments from the Gravity Forms teams saying that they’re looking into this. I suspect (and hope) it won’t be too much longer before this one’s fixed :)

I have exactly the same problem.
I have the gravity pro license and the zpier / gravity plugin, but it doesn't work.

Userlevel 7
Badge +8

Hi @BarVision - I’ve added you to this issue. You’ll be contacted via email if we have an update to share. Thanks!

Yes I saw that.  In my case the integration was working and then stopped functioning so I feel a CDN issue is an unlikely culprit.  Also noted that in @hdav case it allowed the setup of the zap and then didn’t pull the data.  In my case the authentication fails to compete when using Add Connection for the Gravityforms app within Zapier under My Apps.  I need to understand how to proceed.  Is this Gravityforms / Zapier integration recognized as an issue resident within Zapier and is it getting focused attention from your development team?  If not, then we certainly need to press forward here to resolve the matter another way.  Frankly we don’t want to leave Zapier as it does so many things well, but our customers have needs that we’re expected to meet.  I recognize the problem can be multi-factored and in some cases may be caused by user error.  Nonetheless, please advise and help us to have realistic expectations regarding any potential resolution of this matter through changes that may be made by your development team.

You can add me to this list as well, as I have the same issue.


We are trying to connect Zapier and Gravity forms for the first time, and we are also running into this same error. Here is the message we get:

“We hit an error adding your new account

authentication failed: Invalid Base URL.

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information”

Can we get this issue resolved?

Thank you!

I am getting the same issue as well. For one thing I am not getting a permission popup for me to ‘Allow’ or ‘Accept’. Plus its not very clear how double check my account (which account - Zapier, Wordpress user) that has the correct permissions.

This is very frustrating I have to say.

Add me to the list too. Not working and holding up the release of several new site elements.

Userlevel 7
Badge +8

@mduncan I see that you have reached out to Support who has added you to this report. They will be in touch with updates via email as they are available!

Userlevel 3
Badge +6

Hey @Mark Dalton

I just added you to the bug report and we’ll be sure to alert you ASAP once this is resolved!

Yes I concur with @mbprouser.  The message in item 1. above calls out the permission popup but I have yet to see a permission popup in the connection process.  I have tested in Firefox, Brave, and Chrome.  

@Danvers can you add me to, i have the same issue. Running GF 2.5, openlitespeed and cloudflare. thanks!

Userlevel 1


I seemed to have fixed my issue. It turned out that I was getting invalid URL notifications because my wordpress site was pointing to a CDN used by Sitelock, who we use for extra security, and Sitelock were blocking the API. It was a bit of a mess for Sitelock whitelist the Zapier IPs as they use AWS and there’s hundreds of them, and could change in the future, and it let me set up the Zap, but wasn’t pulling the data through. In the end the actual fix was easy: get Sitelock to whitelist the ‘user agent’ for the API, which is literally just “Zapier”. Not sure if that will work for others, but it worked for me. 


Userlevel 7
Badge +11

Everyone: So sorry for the frustrating experience with Gravity Forms and Zapier! Clearly neither us nor GF want this to be the experience for you all. 

I see a response on our bug tracking system from the GF team, quoting one of their users:

Before I started the debugging process i went into our Wordpress instance and upgraded to the latest x.x.24 release of Gravity Forms plugin and then in Zapier I retried reconnecting using the new website url and secret key and password and it worked! I've run a few tests and things seem to be submitting again.

Maybe trying that will help some of y’all as well! If not, there’s the following workaround...


When you say that the webhooks workaround doesn’t work for you, do you mean what this this Community member suggested, to use the Gravity Forms webhook add-on with the catch hook option of Webhooks by Zapier?

Also, I see in the Gravity Forms changelog that they released an update 2 days ago. If you’ve been using the most recent version unsuccessfully, I’d be curious to know if that update has made a difference at all.

If you have not done so already, I’d recommend contacting both the Zapier and Gravity Forms support teams. They’ll have more tools at their disposal and can dig into logs to see what’s happening.

@Secafi and @NTCAdmin:

You’ve both been added to the list of affected users, and what I mentioned above for echo could apply to you as well: try the webhooks workround, see if the latest GF update helps at all, and get in touch with Zapier and GF support teams. It really does seem to be the case when GF digs in that the problem can be caused by different things, so I’d definitely recommend reaching out to their excellent support team.

Userlevel 1

I posted a reply about how I fixed mine - it was to do with my site using Sitelock CDN that was blocking the API, but not sure where the reply has gone

Userlevel 1

This might not work for you, because in my case my wordpress site is using Sitelock, which is pointing the domain to their CDN, and their firewall was blocking the connection. I went onto Sitelock’s support chat, and got them to whitelist the user agent name, which is literally ‘Zapier’ - and now it’s working. So the firewall will scan all API requests with the user agent name Zapier and let those ones through.

Not sure if that’s your case scenario - but worked for me

I’m encountering this issue as well. How do I sign up for updates?  @nicksimard 

Userlevel 7
Badge +11

Hi @mikeguy!

Based on the comments that I see in our system from the folks at Gravity Forms, there are a variety of reasons that this error message could happen. They seem pretty keen to hear directly from users so they can help troubleshoot it, as they work on resolving the issue.

If you haven’t already done so, I’d suggest getting touch with their fantastic Support team as well. In the meantime, I’ve added you as an affected user on our end.

Userlevel 7
Badge +11


I've gone ahead and added you to the list of affected users. We'll let you know via email when that's been resolved!

Userlevel 1

Hi, any news for this issue?

This is absolutely outragiouse!

Can someone please take ownership of this matter and solve it to the benefit of all of us customers, paying both to Zapier and Gravity form, just to end up with two products that cannot work with each other?!

This is devastating for all business who are relying on this to WORK!


Please advise ASAP!

Hi I have one Zap connected and running to one gravity form, I tried to connect a second one but now I am getting the “Invalid base URL” error message. It’s very important and urgent for us to fix this and connect both forms. Please let me know what can I do to fix it. Thank you in advance. 

Also having this issue...

Please add me to the list.  Same issue.

Userlevel 4
Badge +6

Hello @DancingQueen. I hear you and I get your frustration!

I’ve added you to the issue, so you’ll be notified once there is a solution. In the meantime, please do reach out to the Gravity Forms support team as the more customer data they can get - the more likely they can get a solution out to customers sooner. I know there’s been a ton of back and forth between Gravity Forms support and Zapier support trying to figure this out and your information helps.

@Jillian Can you add me as well. I am using CloudFlare and we are unable to connect Gravity Forms.