Best answer

Gravity Forms Connection error

  • 11 March 2021
  • 68 replies


I keep getting Base URL invalid when try to connect Gravity forms app (Auth 2.0)


Best answer by nicksimard 2 August 2021, 19:27

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

68 replies

Userlevel 7
Badge +8

@mikeguy sorry you’re running into this! I have added you as an impacted user and you will receive status updates via email. 

I am experiencing the same issue.  Recently began migration of automations that originate in gravityforms and our initial setup worked then failed a few days later.  Unable to establish an account connection Gravityforms.  Please add me to the impacted user list.  Curious what other users are doing in the interim to work around this issue.  My site visitors aren’t happy with us right now.  Is there a workaround?  And how often does this type of failure happen with zapier?

Userlevel 7
Badge +12

Hi @TimTimany!

Thanks for your message, I’ve added you to the list of affected users, which means that you’ll get an email when the issue is resolved. 

Hi Danvers thank you for your response. Can you make a recommendation of a stopgap work around for us?  I see there are suggestions of allowing the previous version of the integration to work in tandem until the bugs are resolved but maybe this isn’t a practical solution for your programming team.  Please suggest another approach as I know these site responses to customers are a critical matter for many, including myself.

Userlevel 7
Badge +12

Hi @TimTimany 

I’m not aware of an ‘official’ workaround that I can suggest. It looks like @hdav had some luck with this:

It turned out that I was getting invalid URL notifications because my wordpress site was pointing to a CDN used by Sitelock, who we use for extra security, and Sitelock were blocking the API. It was a bit of a mess for Sitelock whitelist the Zapier IPs as they use AWS and there’s hundreds of them, and could change in the future, and it let me set up the Zap, but wasn’t pulling the data through. In the end the actual fix was easy: get Sitelock to whitelist the ‘user agent’ for the API, which is literally just “Zapier”. Not sure if that will work for others, but it worked for me. 

Yes I saw that.  In my case the integration was working and then stopped functioning so I feel a CDN issue is an unlikely culprit.  Also noted that in @hdav case it allowed the setup of the zap and then didn’t pull the data.  In my case the authentication fails to compete when using Add Connection for the Gravityforms app within Zapier under My Apps.  I need to understand how to proceed.  Is this Gravityforms / Zapier integration recognized as an issue resident within Zapier and is it getting focused attention from your development team?  If not, then we certainly need to press forward here to resolve the matter another way.  Frankly we don’t want to leave Zapier as it does so many things well, but our customers have needs that we’re expected to meet.  I recognize the problem can be multi-factored and in some cases may be caused by user error.  Nonetheless, please advise and help us to have realistic expectations regarding any potential resolution of this matter through changes that may be made by your development team.


We are trying to connect Zapier and Gravity forms for the first time, and we are also running into this same error. Here is the message we get:

“We hit an error adding your new account

authentication failed: Invalid Base URL.

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information”

Can we get this issue resolved?

Thank you!

I am getting the same issue as well. For one thing I am not getting a permission popup for me to ‘Allow’ or ‘Accept’. Plus its not very clear how double check my account (which account - Zapier, Wordpress user) that has the correct permissions.

This is very frustrating I have to say.

Yes I concur with @mbprouser.  The message in item 1. above calls out the permission popup but I have yet to see a permission popup in the connection process.  I have tested in Firefox, Brave, and Chrome.  

Please add me to the list.  Same issue.

You can add me to this list as well, as I have the same issue.

Userlevel 7
Badge +11

Hi @mikeguy!

Based on the comments that I see in our system from the folks at Gravity Forms, there are a variety of reasons that this error message could happen. They seem pretty keen to hear directly from users so they can help troubleshoot it, as they work on resolving the issue.

If you haven’t already done so, I’d suggest getting touch with their fantastic Support team as well. In the meantime, I’ve added you as an affected user on our end.

Userlevel 1

Hi, any news for this issue?

I am having the same issue on my side - please add me to the list.  Will we be notified when a resolution is found?

Userlevel 1

1+ month of this issue its unacceptable.

Use addon webooks like workaround not works for me. this is frustrating with a Premium subscription with Zapier and Gravity Form. 1350$ plus 250$ year… 

please add me to the list.



I have exactly the same problem.
I have the gravity pro license and the zpier / gravity plugin, but it doesn't work.

Userlevel 7
Badge +11

Everyone: So sorry for the frustrating experience with Gravity Forms and Zapier! Clearly neither us nor GF want this to be the experience for you all. 

I see a response on our bug tracking system from the GF team, quoting one of their users:

Before I started the debugging process i went into our Wordpress instance and upgraded to the latest x.x.24 release of Gravity Forms plugin and then in Zapier I retried reconnecting using the new website url and secret key and password and it worked! I've run a few tests and things seem to be submitting again.

Maybe trying that will help some of y’all as well! If not, there’s the following workaround...


When you say that the webhooks workaround doesn’t work for you, do you mean what this this Community member suggested, to use the Gravity Forms webhook add-on with the catch hook option of Webhooks by Zapier?

Also, I see in the Gravity Forms changelog that they released an update 2 days ago. If you’ve been using the most recent version unsuccessfully, I’d be curious to know if that update has made a difference at all.

If you have not done so already, I’d recommend contacting both the Zapier and Gravity Forms support teams. They’ll have more tools at their disposal and can dig into logs to see what’s happening.

@Secafi and @NTCAdmin:

You’ve both been added to the list of affected users, and what I mentioned above for echo could apply to you as well: try the webhooks workround, see if the latest GF update helps at all, and get in touch with Zapier and GF support teams. It really does seem to be the case when GF digs in that the problem can be caused by different things, so I’d definitely recommend reaching out to their excellent support team.

Userlevel 1

In case you’re using CloudFlare and you are experiencing this issue, disable “Super Bot Fight Mode” and everything will work. 

Userlevel 1

In case you’re using CloudFlare and you are experiencing this issue, disable “Super Bot Fight Mode” and everything will work. 


This works for me thanks!

Same issue, any status ?  The WP instance is set to auto update Gravity Forms plugin, so version should not be a problem.

Userlevel 1

@john-rl You’ve been added to the report and you’ll be notified once we have a solution. We appreciate your patience!

This is absolutely outragiouse!

Can someone please take ownership of this matter and solve it to the benefit of all of us customers, paying both to Zapier and Gravity form, just to end up with two products that cannot work with each other?!

This is devastating for all business who are relying on this to WORK!


Please advise ASAP!

Userlevel 4
Badge +6

Hello @DancingQueen. I hear you and I get your frustration!

I’ve added you to the issue, so you’ll be notified once there is a solution. In the meantime, please do reach out to the Gravity Forms support team as the more customer data they can get - the more likely they can get a solution out to customers sooner. I know there’s been a ton of back and forth between Gravity Forms support and Zapier support trying to figure this out and your information helps.

I am experiencing the same error.

I am using CloudFlare on the website where Gravity Forms is installed.

Disabling Super Bot Fight Mode in Cloudflare did not fix the error for us.

If disabling Super Bot Fight Mode is fixing it for some users, I believe Zapier needs to look into whether or not this is a CloudFlare firewall related issue. If it is, users will need instructions as to what IP addresses or user agents should be whitelisted.

Userlevel 3
Badge +6

Hey @Anne, hope you are well!

I’ve just went in and made sure you were added to the report so that we can be sure to alert you ASAP once there is a resolution.

In the meantime, if you need access to the IP address range for Zapier, that would be all of US-East-1 from Amazon:

The issue would not be explicitly related to CloudFlare firewall, but any firewall that may be configured to block our IP address range. Sometimes hosts of a domain may automatically have blacklisted IPs from Amazon and this can cause issues as well.

That said, this particular bug is a top priority right now and we are actively working with Gravity Forms to help find a resolution for all of our users. Also, it can be beneficial to reach out to Gravity Forms directly as they are also collecting relevant Gravity Forms user information from their side as well.

Add me to the list too. Not working and holding up the release of several new site elements.