Best answer

Cannot read property 'number' of undefined

  • 22 January 2020
  • 28 replies
  • 6596 views

Userlevel 1

Can someone please explain what this error means. I am trying to create a zap that connect a Squarespace form submission to add a contact to Keller Williams command.


thanks


icon

Best answer by jesse 21 April 2021, 18:34

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

28 replies

Userlevel 3
Badge +1

Hmm this one is strange. It isn't like the typical errors I run into in my day-to-day usage with Zapier. This is because none of the field names you are passing are labeled as "number". It's also tough because I'm not a KW member and can't access the Zap setup to replicate.

One thing you can try before escalating this up the chain to Zapier's engineering team (support@zapier.com) is to skip the testing step and just proceed with your Zap setup. After you do that, you can do a manual run by adding a lead in Squarespace (John Smithson i.e.) and then see what happens.

If the task runs, then GREAT! If it doesn't run, you can check the Task History and look at the error. Screenshot that error and send it back to this forum and then we can advise you on how to fix it, or escalate it to Zapier's engineering team.

Cheers!

Bryan from Workload


Userlevel 1

So after spending a few hours with various lead types I think I finally figured this out. Looks like in my case when the phone ‘number’ was empty, even though it says it is optional, I was getting this error.

To resolve the issue I added another Text Formatter between the steps to give the phone number a default of 888-888-8888. I tested with all leads that were not working previously and that seemed to do the trick.

Userlevel 3
Badge +1

Hi @RealEstateGirlGuru and welcome to the Zapier Community :)


Can you attach a screenshot of the error you are seeing inside of the Zap step when you're testing it? I think that will help me out a bit. I get a lot of these errors from time to time and it could be happening because you have an empty value where there should be 'something'. Or the data is expecting a number and you are sending text.

A screenshot of the previous step's output would be helpful too.

Thanks for asking the community and I hope I can help you out.


Cheers!

Bryan from Workload


Userlevel 7
Badge +12

Hi @Manny B, thanks for sharing the workaround that you found when using test data from Facebook Lead Ads in a Zap!

 

@LNewcomer - it sounds like there’s a bit of confusion here, I’ll do my best to clear things up. 

In terms of managing the KW Command integration, the team at Keller Williams owns and maintains the Zapier integration, so their team will need to add any feature requests/address any issues. The Zapier team has recently reached out to KW to see if we can help them to address this issue/feature request. Fingers crossed we’ll be able to get things moving soon. 

 

We know that Keller Williams updated the integration at the beginning of December. The Create Lead action is no longer available and the Create contact action has been updated. 

 

In terms of the information coming from other apps, I think that you’ll be able to get the best help from the Zapier support team. You can contact them using the Get Help form: https://zapier.com/app/get-help They will be able to take a look at the apps you’re using and how your Zaps are set up so that they can answer your questions 🙂

 

I hope that helps!

 

Userlevel 7
Badge +8

Hi @glenmit ,

Thanks for reaching out!

It seems you have also stumbled upon a known Keller Williams Command app bug. A bug report has been created for the team that looks after the integration, which is a third-party company, and hopefully, that's something they can fix up soon. I've made sure to note that you're affected by the error so we'll notify you via email once there's any news or updates to share.


In the meantime, you might want to also reach out to Keller Williams Command directly and let them know this is something you're experiencing. We’ve found that when our partners hear directly from their own customers, this helps get things moving a bit faster!

Sorry we don’t have better news but please let us know if you have any additional questions!

Userlevel 7
Badge +12

Hi @LNewcomer, I’m sorry that you’re running into this error in your Zap. 

 

We have let the team at Keller Williams know about this issue, and I’ve added you to that report so they know how many users are affected by it - this also means that you’ll get an email from Zapier when the issue is resolved. 

 

You can of course send KW a message yourself, sometimes it helps for an app team to hear directly from their users. 

 

In the meantime, people that hit the same error found that adding a number in the phone number field fixed the error - it looks like the field might be required even though it says that it’s optional. If check the original post in this thread, you’ll see that there’s a ‘best answer’ marked that explains how you can do that. 

 

Userlevel 1

Thanks Liz!

 

Userlevel 1

Here’s a task history entry of the error - 

 

Userlevel 1

Setting up Follow Up Boss and KW Command and ran into the same issue. I was able to successfully set it up with the phone number. I think they just dropped the ball on the interface and it is a required field. @amirdekel got it right. Thanks so much! You should bump his answer to the top since he found the workaround for this and Command still isn’t working. 

Userlevel 3
Badge +1

OH and also reference this thread on the forum so the person helping you will have a frame of reference on everything you already looked into.

It will save you some time repeating yourself. Zapier's team is very efficient and responsive as well.


Userlevel 1

Hey there @workload thanks!


attached is a screenshot of the error when it happens. I believe I entered info in all of the required spots.


thanks!

5E9CAFD4-580B-49D5-BB26-1162BA882A63.pngFF1248E3-E023-4065-8F54-F19DAB2C4770.png


Userlevel 1

Hey, everyone

It seems this is still unresolved for many here, so I’ll share what I’ve found. I think I was able to figure it out. 

I went through the same motions and got the same reply from KW that this is a problem on Zapier’s side and I am still waiting for an answer from Zapier’s support team on the same question.

Here is the deal, when you test your Zap using a dummy lead from Facebook, the Facebook’s dummy ph number is “test_data” or something like that. It seems Command rejects the Zap because it’s trying to save a contact with letters in the ph number field. Ergo, “number undefined”.

To ensure the Zap works, you can test it with the ph number field empty or manually input a default value like 8888888888. The test should work. At that point, you can go back to the “Set up Action” tab and plug the “Facebook phone number” value into the ph number section. Then, click next, Skip the test, and turn on your Zap.

Once your Facebook ad is running and you gain a lead, the Facebook lead form will have the leads’ actual info and thus, have numbers in the ph number section. The lead’s contact info will successfully be added to Command as it won’t reject the ph number portion because the ph number is ‘defined.’

Again, it seems the problem is with the test lead’s dummy data when testing the Zap, not between Facebook and Command or Zapier and Command.

I hope this makes sense. Please reach out if you need me to clarify.

 

-Manny

Userlevel 1

The top of this thread says “Solved” but it doesn’t seem like there is an actual solution. I have tried to add Default Text Formatters by Zapier to get rid of any empty fields and even when all the required fields are filled it still comes through with this error.

Anyone got this to work?

Thanks!

Userlevel 7
Badge +8

Hey @RealEstateGirlGuru - We just wanted to check in to see if you were ever able to resolve the issue? Thanks!

Can someone please, please share how this was resolved. Is it still a bug in KW Command (Zapier)? I’m having the same error only it’s with Listing To Leads - KWCommand. I’ve tried creating default values to using Lookup to change values. I’’m really stuck. 

 

Thanks in advance. 

Userlevel 1

I am getting this error as well. However everything is working and the lead goes from my CRM (Real Geeks) into Command properly. I get an email error though.

 

Userlevel 7
Badge +11

Hi @amirdekel! Thanks for providing that extra context and the workaround that you found. This thread says “solved” because we have an accepted answer (even though the answer is that there is a bug in the KW Command integration that’s causing that issue). So the issue itself is not resolved, but the best answer available here is the one posted by Liz.

@wheathcock @listingsmagic have you managed to resolve this? If not, does the answer by amirdekel help you out at all? I’ve added everyone in this thread to the existing bug report so when it does get fixed you’ll all receive an email notification!

Hi,

Has there been any progress with this bug?  

@amirdekel @nicksimard I’m a Zap novice.  I’m having the same issue.  Can you explain your workaround in more detail? Between what step did you insert the text formatter (I’ll have to figure out what a text formatter is but I think I can figure that out).  I’d like to try your work around.

 

I am also experiencing this same issue. Is this a Command issue or Zapier issue? I believe it is Command related but not an expert in this domain - yet.

Userlevel 7
Badge +12

Hi @seandezahd, thanks for your question about this 🙂

 

The Keller Williams Command app is owned and maintained by their team, and although we have reported this to them we can’t see the progress that they may be making with it. I’ve added you as an affected user on the bug to let the KW team know how many folks are running into this issue. That also means that you’ll get an email when it’s resolved. In the meantime, you could also reach out to the KW team to see if they have any updates. Thanks!

Userlevel 1

Im new to zapier and just got this same message.  was trying to go through the channels to see if its mentioned anywhere and this is all I found.  Any updates?  Im actually trying to send to KW too.

 

Userlevel 3
Badge +1

Hi @RealEstateGirlGuru,

Thanks for bearing with me and providing great screenshots. Are you on a tablet? That's nice!


OK so the last thing I would try before sending this off to Zapier's internal support would be send another test but this time pass along the "Phone" and "Buyer/Seller" fields. I'm wondering if someone marked them as optional but they are actually required fields.

If that doesn't do the trick then send it off to Zapier Support because I'm out of ideas :(

The way to contact Zapier Support is pretty nifty. Go to this site while you're logged in to Zapier:

Zapier | The easiest way to automate your work

And click on this button:


Screen Shot 2020-01-22 at 11.10.09 PM.png


Userlevel 3
Badge +1

Hi @RealEstateGirlGuru ,

Was wondering if anyone from Zapier was able to help out and bring some closure to your issue?

Let me know!

Cheers,

Bryan


Userlevel 1

@workload

thanks! I did try it and it still errors...attached is the error screen.

007EC307-7D29-4132-8012-3863B2A9FF3A.png