Best answer

Zap editing with new Trello custom fields does not work

  • 16 March 2023
  • 9 replies
  • 232 views

Userlevel 1

Hello all,

I have a problem with editing the zaps if in the meantime new custom fields on Trello should be integrated there.

Example:

I have a zap that triggers “card moved to list” on Trello and then sends an email automatically via Outlook.

If I now want to add something to this existing emailtext and for this want to use a new custom field on Trello, which I have created in the meantime, Zapier does not find this field to use it in the text.

If I create a new zap, then it works. However, I would like to use it also in the edit function.

Can someone help me?

Many greetings
Alex 

 

icon

Best answer by Danvers 16 March 2023, 15:43

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +12

Hi there @gses!

If you re-test the trigger of your Zap, it will pull in more recent samples that you can use in the Zap. These should have the fields that you need. 

This help guide explains how to find more samples to use in your Zap: Change the test data in your Zap

 

​I hope that helps, please let us know if you have any questions!

Userlevel 1

Hi @Danvers thanks for your reply.

You mean the trigger “card moved to list” in Trello?

Where can i re:test it?
because on die edit there is only the possibility of “Continue” and “close”.

I also did “refresh fields” but still, the new custom fields are not shown.

kind regards

Userlevel 4
Badge +6

Hi @gses 

My colleague Danvers meant the trigger Trello. Here’s a screenshot where you can load more samples:

0202ca75d9f7ecd6a09c5086cbb5b18c.png
(view larger)

Let us know how it goes!

Userlevel 1

@Brem 
Thank you for your reply. Unfortunately it does not work. I used “load more” and made all steps with continue but still, the new custom fields are not shown in the “Insert Data...” List from all available Trello fields. Is there another way?

Userlevel 7
Badge +9

Hey there, @gses! Ah, I’m sorry to hear that. 

After clicking “Load More” were you able to select one of the new samples that you’ve confirmed has the new custom label in Trello?

Also if I’m not mistaken sometimes the fields come across as custom ID’s. Have you tried flipping over to the custom option?

Here’s a similar topic that touches on this:

Keep us posted!

Userlevel 1

@christina.d thanks for your reply.
The issue is not related to a customized label, but rather to a customized field. Although creating new zaps is not a problem, the challenge lies in editing existing ones. When clicking on "load more," additional options are displayed, and for instance, a card may have been moved to list F instead of my intended choice of List C. This raises the question of how these two actions are connected.

Userlevel 4
Badge +6

Hey @gses 

I just want to confirm, have you done what Christina said, which is selecting the most recent sample on the trigger step? Kindly select the most recent sample trigger and then check if the custom fields are showing so you can use it to map fields in the action step.

Also, could you please ensure that the correct account was connected and the right “Board” was selected?

Userlevel 1

@Brem thanks, the key was “select”
at first i thought “load” would be enough.
now it works 👍

Userlevel 7
Badge +11

Yay! That’s great news @gses! Thanks for hopping back here to confirm that selecting a different sample did the trick.

Happy Zapping! 😁⚡