Twitter URL's posted to Discord show no previews / do not unfurl

  • 19 August 2022
  • 12 replies

Userlevel 1

When using a Twitter Mention trigger and posting it to Discord, what we see is a bare URL text in Discord. It doesn’t unfurl or show a preview. (this is the Zapier bot, I’ve obviously customised it with the name and icon).



If I take the same URL and enter it on its own in a message, it shows the preview / unfurls.


The Zap ‘Message Text’ looks like this:

Any suggestions on this? Is there something else I should be adding here? Is it a permission thing for the bot?

12 replies

Userlevel 3
Badge +3

Hey there @chocopauby 

Welcome to the Community!

Sorry about the bother here, I took a look and found a similar topic from a while back:

Could you try the solution offered in that thread to see if that does the trick for you here?

Let me know if it doesn't so I can do some more digging into what might be the problem here!

Userlevel 1

There is no usable expanded_url option. Unless I’m misunderstanding what the solution was?



Badge +3

Hi @chocopauby,

Thanks for posting in the Zapier Community! Happy to help! 

Could you please try just mapping the Entities Urls Expanded Url (and remove the other values) that shows in your screenshot above? 

When you get a chance, can you give this a shot and let me know how it goes?

Userlevel 1


Still the same ‘No data’.

This is what the Test action looks like (if it helps):


Badge +3

Hi @chocopauby,

It will usually says as ‘No data’ if the current test data from the trigger step (in this case, from Twitter) has no data value for that specific field. However, when the Zap runs live and there’s a value for the Entities Urls Expanded Url then it will show up in the Zap run. 

You could also try to pull fresh sample data from the trigger step. To pull in a live example in the sample data for your trigger, by following these steps:

  1. Open up the app that is sending information to Zapier. Create and submit a new entry that should trigger the Zap
  2. In a separate tab or window, open your Zap, and head to the “Test Trigger” section of the trigger. If sample data already exists, open the dropdown list of samples and select "Load More"
  3. The Zap will spend 10 seconds searching for more samples. If all went as it should, that new entry should appear in the list. If you don’t see that entry, select the “Load More” option again to pull in more samples

This guide can also help provide more details about setting up your Zap’s trigger: 

From there, you can then go your action step and then try to map the Message Text field again and see if there will be a sample value for the Entities Urls Expanded Url. 

When you get a chance, can you give this a shot and let me know how it goes?

Userlevel 1

I followed the steps above:


When I got to Test Action, I got this:


Userlevel 7
Badge +12

Hi @chocopauby!

Thanks for giving that a go :) As there’s no information in the trigger test data, testing the action in the Zap will give you the error message that you saw. Sometimes the data that comes from the trigger test is different from what you’ll see when the Zap is live. Could you try:

  1. Skipping the test on the Discord action
  2. Turning the Zap on
  3. Creating a new tweet


And let us know if that worked? Alternatively, you can use the steps that @EJR outlined above to get a different tweet for the trigger test to see if there is one that has data in the Entities Urls expanded Url field.



I think this is just a problem with Discord. I have the same issue with a totally different Discord bot. It looks like URL unfurling works for app or web users but is broken for data entered via API.

I agree this isn’t a problem with Zapier, but it’s also not a problem with Discord.

It’s Twitter. I feel.

I get the same issue with Telegram. Some links I post unfurl, but the majority don’t.

I actually gave up trying to resolve it. The steps above don’t work at all as the Entities Urls expanded Url is always empty.

My problem was not with links I post manually to Discord, just those via an API. It happens for all links at all times. It’s not Twitter.


Are you telling me that some links posted to Discord API via Zapier actually unfurl?

Userlevel 1

Some do and some don’t. Here is an example of one from 6 October, posted via a Zapier Zap, that did unfurl.

We have a #socials channel in Discord that only Zapier (and me occasionally) posts to. The majority of links now seem to unfurl. Not all.

In contrast, in Telegram (which I mentioned above) the opposite is true - most don’t seem to unfurl but the odd one does. Note that Telegram posts are by me personally and not by Zapier which leads me to believe this is a Twitter issue and not a strictly Zapier one.

Ok, that’s very cool. Do you know what API Zapier is using? I’ll take a “sometimes works” over a “never works” any day 😄