test trigger not working with clickfunnels

  • 7 July 2021
  • 2 replies

I am trying to run a test for Clickfunnels (to link to Thinkific). I have 2 other zaps that work, but this one is not.

The connection is good.

The funnel is good

The step is good

I have a few test purchases, but none are getting through. I have tried testing within a minute and waiting 12 hours. I have used different test ‘names & emails”.

The other two zaps are also with Clickfunnels, on the same funnel (different steps).


Help please ...



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +9

Hi @Dom202020,

You should try the following steps: 

  • Create a new Zap: Clickfunnel trigger is an instant trigger and it creates a webhook, in some cases, this may not get registered on the Clickfunnel end. So create a new Zap and then add clickfunnel trigger.
  • Reconnect your account: Reconnecting your account should solve this issue if it’s related to account.
  • Double check your funnel: Make sure you have the right funnel selected in the trigger. If still doesn’t work, duplicate the funnel and select the duplicated funnel in zapier.

Hi Rob,

Thanks for replying.

I have two other zaps that work with this funnel. I have tried several new zaps, tried reconnecting the Clickfunnel service. I am hesitant to use a copied funnel as this means I need to reconfigure many aspects of the funnel to make it operational (even for a zap test). I am also hesitant if I have two zaps already working within this funnel.

I’ve tried using a if/then statement (or Action) but using some other data. that didn’t work either.

A key point… When I run the test trigger, only 2 purchases come through (the first 2 I tested) even though I have tested over 10. Is there something else going on..?

Thanks in advance.