Best answer

Google Spreadsheet row to Google Doc Template - fields missing

I’ve set up a Zap that pulls updated Google spreadsheet row data into a Google doc template.

I’ve tested it a few times and all is working; except 6 fields that won’t pull through to the ‘set up action’ when building the zap.

I have all the correct {{placeholder}} fields in the /google doc, matching spreadsheet header columns.


Here’s the Google spreadsheet: (highlighted fields are the ones that are broken)

Here’s the Google Doc template:

And here’s the Zap build:


Any help with troubleshooting why 6 fields aren't pulling through would be great.



Best answer by christina.d 15 July 2022, 20:28

View original

11 replies

Userlevel 7
Badge +14


Good question.

My template fields aren't appearing in Zapier or they all have generic names

This may be due to your template format. Remove any HTML formatting, and check your template field formatting.

Remove any HTML formatting

If you copy and pasted fields in your template, they may contain HTML formatting. The HTML formatting won't be visible in your Google Doc, but you will need to remove it before using your Doc in Zapier.

There are two ways to delete the HTML in your Google Docs template:

Manually enter the template field

  1. Delete the template field and the text around the template field
  2. Manually type in the template field and the text around it.

Remove formatting

  1. Highlight the template fields.
  2. In the top menu, click Format.
  3. Select Clear formatting.

If you already selected the template in your Zap, click Refresh fields at the bottom of your Google Docs step. This will reload your template and display your template fields.

Check your template field formatting

To correctly format your template fields in Google Docs:

  • Template fields must be wrapped in double curly braces.
  • Remove any spaces.
  • Remove any special characters like punctuation marks.

Here’s an example of a properly formatted template field: {{MyTemplateField}}.

Learn more about how to create and autopopulate a Google Docs template.

My template doesn't appear in the Create Document from Template Action step

The Create Document from Template Action will only display templates that you created in Google Docs. It won't display existing templates created by Google Docs. Learn more about each template type.

Hi Troy,


Thanks for your help with this! I rebuilt the Google Doc template with {{MyTemplateField}} and the test went through great.


When I ran the zap all the data came through incorrectly (and now I’ve run out of tasks!)


The {{Name}} {{Surname}} 2022 should generate the google doc file name but it’s hooking up with other fields -


Not sure how to solve this.


Userlevel 7
Badge +14


Make sure your fields are still mapped correctly in the Zap action step that created the GDoc template.

Your Zap Runs history shows the DATA IN/OUT for each Zap step to help you troubleshoot:

Userlevel 7
Badge +9

Hey there, @CPS! I wanted to swing by and see if you were able to get this sorted?
I took a quick peek at your ticket and it sounds like you may have, which is perfect! Would you mind sharing your solution? We’d love to know. 🤗


Sadly this isn’t solved.

The zap was still pulling through incorrect fields, so I have decided to turn off the Zap and try and build a new one.

I’m trying to set up a new Zap, but am failing at 2 Create Document from Template in Google Docs stage - it can’t find the Google Doc template file in the set up action > template document.


Why is this proving to be such a headache? :(



Userlevel 7
Badge +9

Hey @CPS oh no, so sorry this has been such a hassle! Let’s see if we can get to the bottom of this. Can you confirm for me the template doesn’t exist on a team drive? I came across this thread which confirms we cannot find a template on a team drive but offers a workaround to get the template ID if this isn’t the case: 

Can you tell us more about the incorrect field issue as well? We’d love to keep working through this one with you!

Hey Jessie,


Thanks for getting back to me. The drive isn’t a team drive, and I managed to get it connected to the word template doc the first time round (lets call this Zap 1 - this zap was pulling incorrect fields) so have turned Zap 1 off.

This (Zap 2) can’t find the template document from my google drive, but it can find the Google sheet. 

Do I need to disconnect and reconnect my google drive to Zapier? Will this affect my other (working) zaps?


Here's what the zap looks like, unable to find any google doc files



Userlevel 7
Badge +9

Hey @CPS Hmm, this one has me stumped as well! Is “Zap 2” still not able to find the template even if you use this workaround? 

Are you the owner/creator of that document? If you reconnect the account (without disconnecting it first) it shouldn’t affect your working Zaps. More into on reconnecting, here if you’re curious:

If things still aren’t working after using the template ID and reconnecting, it’s likely time to take this one to our support team for further digging:

Hey Jesse,


Thanks for getting back to me.

I’ve reconnected the google docs & sheets and both are saying test successful

(not sure why it says the account email address on the Google Sheets and not the Docs, even though they are the same account.)


I made a new Zap from scratch (Zap 3) after reconnecting and still coming up with the same issue of not being able to find any Google Docs.


Will email support now with a copy of this thread.

Thanks for your help on this!

Userlevel 7
Badge +9

Hey there, @CPS

I double checked and can see you were able to open a ticket with support. Looks like they shared this recommendation:

I took a look and was able to pull this in by adding the Doc ID as a custom value in the Zap. Please see below on how to do this in the future. This will then bring in all template fields which you can then map out as usual!


I edited out the actual Doc ID from the original screenshot but it is everything following /d and before the trailing /

I hope this helps!