Best answer

Gmail to Asana Zap: Tasks Aren't Created?

  • 17 April 2023
  • 7 replies
  • 89 views

Userlevel 1

Hi everyone! I’m a property manager and I’ve decided to automate the handling of maintenance requests. My zap is supposed to start after I approve a repair request and an email is forwarded to my staff’s shared inbox.

 

Here’s how it’s supposed to work:

  1. The staff email address gets the copy of the request
  2. Zapier is supposed to recognize the email through “New Email Matching Search in Gmail”
  3. The email content goes through a number of formatting zaps to extract information crucial to creating the task in Asana
  4. The task is created using the outputs of all of those formatting zaps & is posted to the appropriate Asana board

This is my only Asana zap.

 

Quick Overview of the Zap Sequence

 

 

Here’s the problem:

When tested individually, all of the tasks work fine. I get appropriate outputs every step of the way. When I get all the way to the end, if I test the “Create Task in Asana” part, it generates just fine manually. However, this will not generate on it’s own!

  • The zap is published
  • Each step responds appropriately during testing
  • I don’t get any warnings/errors

However, this will NOT WORK automatically, no matter how much time has passed which is problematic for my business.

 

Any ideas on what’s wrong?

icon

Best answer by christina.d 28 April 2023, 23:36

View original

7 replies

Userlevel 3
Badge +4

Hi @When Jess Zaps 

Thanks for reaching out to the Community!

To ensure we’re on the same page, could you confirm what you mean by it not working automatically? Do you mean to say that the Zap has not yet been triggered since it’s been turned on? Or do you have to trigger the Zap manually for it to work?

Looking forward to your response. That’ll help me make sure I give you the best suggestion possible.

Userlevel 7
Badge +8

Hi @When Jess Zaps  welcome to Zapier Community 👋 -

Hmm, okay since this is a five step Zap, I’d like to start looking at individual steps. Can you please share a screenshot of the Zap setup in your Step 1 and Step 5? Of course, omitting an personal or identifying information. Additionally, in your Zap History, what information appears there, if any? A screenshot of that would be super helpful as well! 

Userlevel 1

Hi @When Jess Zaps 

Thanks for reaching out to the Community!

To ensure we’re on the same page, could you confirm what you mean by it not working automatically? Do you mean to say that the Zap has not yet been triggered since it’s been turned on? Or do you have to trigger the Zap manually for it to work?

Looking forward to your response. That’ll help me make sure I give you the best suggestion possible.

It does not trigger on it’s own. I don’t think it’s the initial Gmail step because when I go into the zap manually to test it, it finds the email just fine. But if I have to do it manually, it just defeats the purpose of having a zap at all :(

Userlevel 1

Hi @When Jess Zaps  welcome to Zapier Community 👋 -

Hmm, okay since this is a five step Zap, I’d like to start looking at individual steps. Can you please share a screenshot of the Zap setup in your Step 1 and Step 5? Of course, omitting an personal or identifying information. Additionally, in your Zap History, what information appears there, if any? A screenshot of that would be super helpful as well! 

 

Sure!

 

Here is the search string for the Step 1 in Gmail:

 

 

And…. here is Step 5 for the Asana Task Creation:

 

 

Userlevel 4
Badge +6

Hi @When Jess Zaps 

Jumping in to see if I can help!

Can you please try to turn the Zap off and then turn it back on again after a minute so that the Zap will be refreshed?

Userlevel 1

Hi @When Jess Zaps 

Jumping in to see if I can help!

Can you please try to turn the Zap off and then turn it back on again after a minute so that the Zap will be refreshed?

Hello! I tried it and it still doesn’t work :(

Userlevel 7
Badge +9

Hey there, @When Jess Zaps - sorry to hear you’re running into this and appreciate you sharing those extra details. 

I’m sorry to say, it sounds like you may be running into a known bug with the “New Email Matching Search in Gmail” trigger where it isn’t triggering when it should. 😔 My teammate Sam did share a workaround here:

Do you think that might work for your use case instead of the search trigger?

In the meantime, I did add you to the bug report so we’ll be sure to email you once a fix is in place. We’ll also keep that thread updated as well. 👆🏽

Keep us posted!

Reply