Best answer

Failed to create a database item in Notion: {variable} is expected to be rich_text.

  • 20 November 2023
  • 10 replies


I’ve create a Notino database with the column named TestA, and it’s a text column. 

I’m pulling some data from Asana (custom Extension App), and when I put the output to the Notion database I always have this errorr: {variable} is expected to be rich_text.

None of the options under “Formatter by Zapier” helped.


Does anyone knows how to get rid of this error?


Best answer by Troy Tessalone 20 November 2023, 19:29

View original

10 replies

Userlevel 7
Badge +14

Hi @trzsfolio 

Good question.

Can you post screenshots to give us more context?

Hi @Troy Tessalone 


I’ve attached the screenshot of the error, the action and the data used for the action. 


Userlevel 7
Badge +14


Only 1 of the 4 attachments uploaded.


Hi @Troy Tessalone 

I’ve re-uploaded the files. 

Userlevel 7
Badge +14


The field “Some testing” is a dropdown field that has a list of options.

Check this help article about how to map dynamic values properly:



The field “Some testing” is a text column in a Notion database. 
I don’t want to use the dropdown field. This is why I used the custom configuration because I want to take a custom value from an output of the App Extension from the 4th step. 

Userlevel 7
Badge +14


According to the screenshots you provided the field is a dropdown field.

You may need to refresh the fields in the Notion Zap step.

Can you post screenshots with how the field is configured in Notion?

@Troy Tessalone sure. 

The issue is that the text from the custom value isn’t rich text. And Notion only accepts rich text for Databases. 


Userlevel 7
Badge +14


Please provide these 2 screenshots:

  1. How the field is configured in Notion
  2. The list of options from the ‘Some testings’ tab to the left of the ‘Custom’ tab.


Hi @Troy Tessalone 
I found out the issue. 

The Notion fields weren’t correctly refreshed the first time. 


After refreshing it, it was working. 

Thanks for the help !