Best answer

Amazon S3 Bucket error: A File could not be found. Bucket "[mybucketname]" does not exist.

Userlevel 1

Trying to connect S3 to Google drive.  I am able to enter the access and secret to my bucket and the bucket is found (and it has files within) but Zapier is reporting (after successfully connecting) that “bucket does not exists” and no files found.  Specifically:

Find Data (error)

  • A File could not be found.

    Bucket "[mybucketname]" does not exist.

I’ve tried everything I can think of here… all I want to do is move everything from S3 to Google drive.  Is this possible?


Best answer by Liz_Roberts 23 July 2020, 20:56

View original

38 replies

Userlevel 7
Badge +8

Hi there @asago - Thanks for the question! That error appears when it cannot find new data associated with the Zap. However, that doesn’t mean that your data isn’t there in the bucket. Our Zapbook about Amazon S3 is outlined here: - It seems the only two Triggers we have at the moment are “New Bucket” and then “New or Updated File” - Could you confirm which of the two triggers you’re trying when you’re seeing that error?


Userlevel 1

Same issue as OP using the New or Updated file… works fine until the test section… 

  1. bucket was empty press test. Response - the bucket “Bucket-Name” does not exist.
  2. upload a new file to the bucket, press test. Response - the bucket “Bucket-Name” does not exist.

Tested permissions with script and it is fine for the access keys given, also tried AmazonS3FullAccess policy to see if it was part of the read only settings… but still did nothing…. useless. 

Userlevel 7
Badge +8

Hi @wdenny3885 ,

I see you are working with Caleb in Support on this issue and have stumbled upon a bug with the S3 integration. You have been added to the bug report which means you will be notified when there is an update. 

I see Caleb suggested a possible workaround some folks have found is to move the S3 bucket to the "N California" region which may be helpful as this bug is worked out. 

I know that’s not the answer you were hoping for, but please let us know if you have any additional questions!



Any resolution on this? Having the same issue with the Zap.

Userlevel 7
Badge +8

@user123123 - I afraid there is not an update as of yet. I have added you to the report as an impacted user so that you will be notified once there is an update. 

In the meantime, hoping the workaround mentioned above may be an option for you!

Userlevel 1

Hi Liz,

I am having the same issue. I’m trying to connect a Box folder to an S3 bucket. The trigger is meant to fire when a file is uploaded to a folder within Box and should upload the file to an S3 bucket. When it comes to choosing a bucket, I get this general error after several seconds in the right sidebar that says:

“We’re having trouble loading 'Bucket Name' data

Uh oh, something is not quite right! This might be a temporary problem though, so you may want to try that again or contact support if this persists!”

None of the S3 buckets, whether they are in the North California region or not, are showing.

Since the API that finds bucket names fails, I would appreciate it if I could enter the name of the bucket manually instead.

Also, I believe that the “Bucket Name” field should probably be required. It is currently optional.

Of course, the test of the integration fails since the bucket name is empty.

Same issue with me.


The IAM user has full S3 permissions. When I customize the file, it queries S3 and finds the bucket name. When I test the trigger I get “A file could not be found” and then underneath that it tells me the bucket I select does not exist.

It both exists and there is data in the bucket.

Userlevel 7
Badge +12

@gherkin and @Concierge I’m sorry that this issue is causing trouble for you. I’ve added you both to the bug report for this, which lets the team know how many users have been affected and means that we’ll send you an email when we have an update. 


Any update on this issue? Having the exact same problem. Moving S3 bucket to a random region because this bug is not solved is not an option.

Userlevel 7
Badge +8

@santiagoc - so sorry you are running into this issue. I have added you to the bug report so that you will be notified of any updates via email. 

I am having the same problem.

Hi, trying to add form data to an S3 bucket but I get this error: We’re having trouble loading 'Bucket Name' data”


Is this a bug?




Userlevel 7
Badge +8

Hi @Johnh! It’s possible this may be the same bug, but I suggest reaching out to our Support team so that they might confirm. They can look at your specific configuration to troubleshoot and/or add you to a bug report if needed. They can be reached here!

Same problem. Since this hasn’t been fixed for such a long time, does anyone know of an alternative to Zapier for this use case?


I have the same issue as mentioned above… Any news of a fix ?





Userlevel 7
Badge +8

Hi @jean-stonly - sorry you are running into this! I have added you as an impacted user, which means you will receive updates via email. I see that one user has had success by "changing the policy to make it less specific for the Keys.” I’m not sure if that is helpful in your case but worth sharing!

Thanks for your answer - unfortunately this didn’t help.

Do you have any visibility on a due date for this fix ?

Userlevel 1


We have the same issue : we try to make a copy of all our S3 bucket to google drive.

S3 Bucket is in Europe west region, and as the company is based in France, we cannot move the bucket to California or anything like that.

Any solution?

Any date about fixing this bug?

Userlevel 7
Badge +11

Hi @jean-stonly and @beyondgravity!

While I’m not able to provide an ETA for this to be fixed, I can pass along what one user said to our Support team that got things working for them.

They said:

I ended up changing the policy to make it less specific for the Keys and got it working. Since I am the only one with access to the zapier account and the bucket.

Full disclosure: I’m not totally familiar with what they’re suggesting, but if this makes sense to you and is something you’re able to do, it may be worth trying.

Userlevel 1

I ended up changing the policy to make it less specific for the Keys and got it working. Since I am the only one with access to the zapier account and the bucket.


I guess they mean giving more access to the AWS service account that it should need, like for example, giving it full write/read access.

I already tried it, but it didn’t worked out for me.

Anyway, thanks for the help, i found another complete different solution to solve my problem.

Userlevel 7
Badge +11

Hey @beyondgravity!

It’s too bad that the suggestion didn’t help, but I’m glad you found something that works for you :) 

No updates still?


The s3 New or Updated File Trigger doesn’t work at all and it’s a premium integration, one that we are paying for and need badly. I’ve tried making the bucket region northern california, ive tried making the bucket completely public, ive tried making the IAM permissions completely open. 

Nothing is working, and i continue to get the error message that the bucket does not exist when i try to test it.

Userlevel 7
Badge +11

Hi @david123!

I understand how frustrating this issue is, and I apologize for the inconvenience of it all. 

We have a multi-faceted prioritization system in place, with teams looking at all of the various requests that we have. Part of it is no doubt whether the integration is a premium one, but there are other factors as well (including how many users it impacts).

As much as I wish I could give you an ETA for when this will be resolved, that’s not something I can provide.

I get that this isn’t necessarily a satisfying answer, but it's the best I can offer right now. You'll be notified this bug has been resolved, and hopefully that's sooner than later!

Sure, i totally understand how you have deprioritized this and dont think its worth fixing now. That’s fine, but you CANT claim to have a premium S3 integration on your site then and not fix it for more than 10 months with no timeline for a fix. That’s borderline fraud.

To be perfectly clear - your S3 integration does not work, at all, in any capacity right now. I have tried every single method triggering it and there is no way to get it to function. 

This is not a minor bug that only affects some specific edge cases. The integration is NOT FUNCTIONAL.

So either fix this, or remove the integration from your site and stop claiming you have it. 

Userlevel 7
Badge +11

Hey @david123,

I agree with you that this is certainly worth fixing but with limited resources we do have to make decisions on what to address first.

If the integration didn’t work at all, for anyone whatsoever, then of course we would not claim to have such an integration and call it premium. The fact is that this bug affects a relatively small percentage of users. There are hundreds of live and functional Zaps, where the users have managed to connect the account and successfully test the trigger. 

Again, I’m really sorry that you (and the others in this thread) are not able to get it working. I really am. It may not feel like a minor bug to you since it’s a total blocker, but it is the case that most people who are using the Amazon S3 integration are doing so successfully (which I understand is no consolation to you).

It doesn’t look like you’ve reached out to our Support team yet about this particular issue. I certainly can’t promise that they’ll be able to resolve this for you, but they have access to more resources than we do here in Community and may have some workarounds that haven’t been mentioned in this thread.