Best answer

Amazon S3 Bucket error: A File could not be found. Bucket "[mybucketname]" does not exist.

Show first post

38 replies

Userlevel 7
Badge +8

Hi @Johnh! It’s possible this may be the same bug, but I suggest reaching out to our Support team so that they might confirm. They can look at your specific configuration to troubleshoot and/or add you to a bug report if needed. They can be reached here!

Hi, trying to add form data to an S3 bucket but I get this error: We’re having trouble loading 'Bucket Name' data”


Is this a bug?




I am having the same problem.

Userlevel 7
Badge +8

@santiagoc - so sorry you are running into this issue. I have added you to the bug report so that you will be notified of any updates via email. 


Any update on this issue? Having the exact same problem. Moving S3 bucket to a random region because this bug is not solved is not an option.

Userlevel 7
Badge +12

@gherkin and @Concierge I’m sorry that this issue is causing trouble for you. I’ve added you both to the bug report for this, which lets the team know how many users have been affected and means that we’ll send you an email when we have an update. 

Same issue with me.


The IAM user has full S3 permissions. When I customize the file, it queries S3 and finds the bucket name. When I test the trigger I get “A file could not be found” and then underneath that it tells me the bucket I select does not exist.

It both exists and there is data in the bucket.

Userlevel 1

Hi Liz,

I am having the same issue. I’m trying to connect a Box folder to an S3 bucket. The trigger is meant to fire when a file is uploaded to a folder within Box and should upload the file to an S3 bucket. When it comes to choosing a bucket, I get this general error after several seconds in the right sidebar that says:

“We’re having trouble loading 'Bucket Name' data

Uh oh, something is not quite right! This might be a temporary problem though, so you may want to try that again or contact support if this persists!”

None of the S3 buckets, whether they are in the North California region or not, are showing.

Since the API that finds bucket names fails, I would appreciate it if I could enter the name of the bucket manually instead.

Also, I believe that the “Bucket Name” field should probably be required. It is currently optional.

Of course, the test of the integration fails since the bucket name is empty.

Userlevel 7
Badge +8

@user123123 - I afraid there is not an update as of yet. I have added you to the report as an impacted user so that you will be notified once there is an update. 

In the meantime, hoping the workaround mentioned above may be an option for you!

Any resolution on this? Having the same issue with the Zap.

Userlevel 7
Badge +8

Hi @wdenny3885 ,

I see you are working with Caleb in Support on this issue and have stumbled upon a bug with the S3 integration. You have been added to the bug report which means you will be notified when there is an update. 

I see Caleb suggested a possible workaround some folks have found is to move the S3 bucket to the "N California" region which may be helpful as this bug is worked out. 

I know that’s not the answer you were hoping for, but please let us know if you have any additional questions!



Userlevel 1

Same issue as OP using the New or Updated file… works fine until the test section… 

  1. bucket was empty press test. Response - the bucket “Bucket-Name” does not exist.
  2. upload a new file to the bucket, press test. Response - the bucket “Bucket-Name” does not exist.

Tested permissions with script and it is fine for the access keys given, also tried AmazonS3FullAccess policy to see if it was part of the read only settings… but still did nothing…. useless. 

Userlevel 7
Badge +8

Hi there @asago - Thanks for the question! That error appears when it cannot find new data associated with the Zap. However, that doesn’t mean that your data isn’t there in the bucket. Our Zapbook about Amazon S3 is outlined here: - It seems the only two Triggers we have at the moment are “New Bucket” and then “New or Updated File” - Could you confirm which of the two triggers you’re trying when you’re seeing that error?