How do I convert a Google Slide presentation to plain text through Zapier?

  • 10 July 2023
  • 5 replies

Hey All!


I’ve been trying to convert a google slide presentation to plain text… but have been failing miserably. I’ve tried CloudConvert, CloudAPI and even using google drive… but nothing.

Was anyone able to do it through Zapier?


I just need to convert one specific slide for every presentation within a folder.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Product Ops Afficionado 

Good question.

Can you provide more specifics and an example with screenshots about what you mean by convert a slide to text?

Sure. I am creating an automation for a user research repository.

What I want to do is…

  1. Every time a presentation is added, the zapier recognises the presentation.
  2. The it reads the second slide (it will always be the second slide) and extract the text from that specific slide.
  3. I’ll use that text to compose the info elsewhere. 


So far, I’ve tried…

  1. converting the google slides to text
  2. using a converter to change from slides to text. I tried ConvertCloud, but it’s giving errors all the time.
  3. reading the file directly and getting the info, to parse it.
  4. Using GET (I suck at it) to try a python code approach, but wasn’t very successful because Zapier isn’t able to import googleapi libraries.

Here’s the screen shot, it’s a pretty simple one.



Userlevel 7
Badge +14

@Product Ops Afficionado 

The GSlides API would likely have to be used:

Zap action: GSlides - API Request


Then some data parsing logic would have to be applied to extract the desired data.

Possibly using AI.

Zap action: ChatGPT - Extract Structured Data


If you need help, consider hiring a Certified Zapier Expert:

Sorry, but I was looking for understanding how to configure the API Request. I’m just getting “Raw request failed.”

Userlevel 7
Badge +11

Hi @Product Ops Afficionado! 👋

Can you share a quick screenshot showing the current setup in the Action section of the action step that’s giving you that “Raw request failed” error? That’ll help us to see if there’s anything in the setup there which might need to be tweaked in order to get it working. Please remove/hide any private information from the screenshot before sharing (like names, email addresses etc.).

Looking forward to hearing from you on this!