Best answer

Does anyone have the Facebook Conversions API actually working?


Userlevel 1

Hello,

Given the rollout of iOS 14.5 this week, we’re keen to get the Salesforce → Zapier → Facebook Conversions API working.

However, we’re stuck.

We’ve got the data flowing from Salesforce to Zapier no problem. And it *appears* like we’ve got the data flowing from Zapier to FB Conversion API (we get a success response from FB).

However, in the FB Event Manager, we see this:

 

Which would imply that the events are not getting passed through to FB because there would more than our 1 test event showing up.

If you’ve got this working, can you raise your hand so I can ask you a few questions about your set-up?

Thank you!

Phillip.

icon

Best answer by nicksimard 8 May 2021, 00:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

54 replies

Userlevel 1

Same problem here, please fix this! We bought zapier for facebook conversions tool. 

We are also having this issue. 

 

Could you please add me to the list of affected users that would be greatly appreciated.

 

If you could add ----------------------------- too that would be sensational.

This post has been edited by a moderator to remove sensitive information. Please remember to obfuscate any personally identifiable information prior to posting as this is a public forum.

Thanks

Me too please - same situation as above. All looks good in Zapier, but no updates in Facebook Ads Manager.

Also experiencing the same issue. I’ve never had it properly working, and have just tried to set it up again and running into the same issue. Everything looks fine, but the test code from Facebook never triggers any events on Facebooks side even though everything looks fine on Zapier. 

Userlevel 1

I’m far from an expert in this domain, but I stumbled my way through setting things up (correctly, I think) but also can’t get anything to show up on the Facebook side of things (both with testing and when the Zap is live). I don’t know where the disconnect lies, since it appears to be going through, based on the success message in my Zap. 

I’d suggest getting in touch with our Support team and referencing this thread, to say that the responses are showing the same problem across multiple users, with no solutions. If there’s a bug then they can create a report and add users to it!

 

@nicksimard I’ve already been in touch with the support team -- they directed me here to the community. 🤦‍♂️

Userlevel 7
Badge +10

Hey @GeorgeCouda

I’ve added you both to the list of affected users. We will email you as soon as there’s been an update. :)  

Userlevel 7
Badge +10

You got it, @MattBlvd!

I’ve added you to the list of affected users as well. Still no news on this but we’ll be in touch as soon as we’ve got an update! :) 

Hi.. I’m guessing this has not been resolved as we have been trying to sort this for weeks without realizing there was an issue.

Could you please provide an update (if we have one) and add me to list to get notified when we do.

Thx

I got the same problem! Please add me to the list of affected users and please fix it right now because this is a big issue that impacts a lot on all, it’s a disaster!

@phillipadsmith  @nicksimard 

Any updates?

Same situation here.  

I have entered the test event code correctly. And on FB side pixel test event side, it doesn’t receive anything. 

Everything good on the Zapier side, but the facebook Conversion API doesn't seem to receive anything.

 

 

Userlevel 7
Badge +10

Hey @MikeS! Still no updates to share at this point, unfortunately. I’ve added you to the list of affected users so we’ll notify you by email as soon as it’s been resolved. 

Any updates? 17 days pass..

RIP Zapier Conversion API, stopped working

Zapier saying test went successfully 

It’s not showing up in event history

Userlevel 7
Badge +10

Hey @Zack! :) 

I’ve added you to the list of affected users too. I don’t know when it will be sorted (hopefully soon!) but we’ll definitely email you as soon as it’s resolved.

Userlevel 7
Badge +14

Hi @phillipadsmith 

Have you tried opening a ticket with Zapier Support? https://zapier.com/app/get-help

Userlevel 1

Hi @Troy Tessalone,

Yes, they directed me here.

Phillip.

Userlevel 7
Badge +14

@phillipadsmith

Have you checked your Zap Runs history details (https://zapier.com/app/history/) for the DATA IN/OUT for each Step to see if there is anything there indicating an issue?

 

Same problem, please resolve soon! add me to list

 

Userlevel 7
Badge +10

Hey @jowett,

I’m so sorry you’re running into this issue as well. I’ve done some checking on this end and we don’t have any updates on the bug report at the moment. I’ve added you to the list of affected users so that we can email you as soon as it’s resolved.

We’ll also post an update on the thread here once we’ve got word that it’s been fixed! :)

Userlevel 7
Badge +11

Hey @phillipadsmith!

I see they’ve responded to you, and we’ve got an open bug report that you’ve been added to. As they mentioned, you’ll be notified via email when that’s been resolved. Again, so sorry about the inconvenience with this!

Userlevel 7
Badge +10

Welcome to the Community, @niceasheck

I’ve added you to the list of affected users now. We will be in touch by email as soon as it’s been sorted! :)

Userlevel 7
Badge +9

Thanks so much for reaching out, @sjcwhetton. I’ve gone ahead and added you to the list of affected users. We’ll be sure to keep you in the loop once this is resolved. 

Userlevel 7
Badge +10

Thanks for letting us know, @ricardovice. I’ve added you to the list of affected users as well. We’ll email you as soon as we have an update to share on this! 

Userlevel 7
Badge +10

Hey @alter, welcome to the Community! :)

We’ve not got any updates on this at the moment unfortunately. In the meantime, I’ve added you to the list of affected users so that we can notify you by email the moment it’s fixed!

Userlevel 1

Please add me to that list as well.  I have gotten further than most it seems, as I am triggering events however there does not seem to be a way to create/pass unique event ID’s that would trigger even deduplication which is required when using both Browser and Server side event tracking.

Happy to share what we did to at least get the event firing.  (we are using unbounce for our landing pages)