Best answer

Does anyone have the Facebook Conversions API actually working?


Userlevel 1

Hello,

Given the rollout of iOS 14.5 this week, we’re keen to get the Salesforce → Zapier → Facebook Conversions API working.

However, we’re stuck.

We’ve got the data flowing from Salesforce to Zapier no problem. And it *appears* like we’ve got the data flowing from Zapier to FB Conversion API (we get a success response from FB).

However, in the FB Event Manager, we see this:

 

Which would imply that the events are not getting passed through to FB because there would more than our 1 test event showing up.

If you’ve got this working, can you raise your hand so I can ask you a few questions about your set-up?

Thank you!

Phillip.

icon

Best answer by nicksimard 8 May 2021, 00:08

I’m far from an expert in this domain, but I stumbled my way through setting things up (correctly, I think) but also can’t get anything to show up on the Facebook side of things (both with testing and when the Zap is live). I don’t know where the disconnect lies, since it appears to be going through, based on the success message in my Zap. 

I’d suggest getting in touch with our Support team and referencing this thread, to say that the responses are showing the same problem across multiple users, with no solutions. If there’s a bug then they can create a report and add users to it!

View original

38 replies

Userlevel 7
Badge +11

Hi @phillipadsmith 

Have you tried opening a ticket with Zapier Support? https://zapier.com/app/get-help

Userlevel 1

Hi @Troy Tessalone,

Yes, they directed me here.

Phillip.

Userlevel 7
Badge +11

@phillipadsmith

Have you checked your Zap Runs history details (https://zapier.com/app/history/) for the DATA IN/OUT for each Step to see if there is anything there indicating an issue?

 

Userlevel 1

@phillipadsmith

Have you checked your Zap Runs history details (https://zapier.com/app/history/) for the DATA IN/OUT for each Step to see if there is anything there indicating an issue?

 

Yep, have done so. No errors.

Userlevel 7
Badge +11

@phillipadsmith 

Can you confirm the Zap is triggering as expected?

Can you confirm you’re getting a proper response from Facebook as part of the DATA OUT for the Facebook step in the Zap?

Perhaps provide screenshots to elaborate.

RIP Zapier Conversion API, stopped working

Zapier saying test went successfully 

It’s not showing up in event history

RIP Zapier Conversion API, stopped working

Zapier saying test went successfully 

It’s not showing up in event history

It seems to be the same situation here. Everything ok on the Zapier side, but the API doesn't seem to receive anything, not even a test.

 

Okay I found something related to this here https://developers.facebook.com/support/bugs/3771331922945801/?join_id=f26ee55e4b43ee8

 

Can anyone tell me what this means:

"You can use real user data (hashed email, phone) for identity matching to succeed"

Userlevel 7
Badge +10

I’m far from an expert in this domain, but I stumbled my way through setting things up (correctly, I think) but also can’t get anything to show up on the Facebook side of things (both with testing and when the Zap is live). I don’t know where the disconnect lies, since it appears to be going through, based on the success message in my Zap. 

I’d suggest getting in touch with our Support team and referencing this thread, to say that the responses are showing the same problem across multiple users, with no solutions. If there’s a bug then they can create a report and add users to it!

Userlevel 1

I’m far from an expert in this domain, but I stumbled my way through setting things up (correctly, I think) but also can’t get anything to show up on the Facebook side of things (both with testing and when the Zap is live). I don’t know where the disconnect lies, since it appears to be going through, based on the success message in my Zap. 

I’d suggest getting in touch with our Support team and referencing this thread, to say that the responses are showing the same problem across multiple users, with no solutions. If there’s a bug then they can create a report and add users to it!

 

@nicksimard I’ve already been in touch with the support team -- they directed me here to the community. 🤦‍♂️

Userlevel 7
Badge +10

Hey @phillipadsmith!

I see they’ve responded to you, and we’ve got an open bug report that you’ve been added to. As they mentioned, you’ll be notified via email when that’s been resolved. Again, so sorry about the inconvenience with this!

@phillipadsmith @nicksimard 

Have you guys seen any progress on this issue. Just tried setting up a test and I’m experiencing the same thing. 

Everything looks good on zapier’s end, successful test, but nothing showing in FB test events.

Userlevel 1

@phillipadsmith @nicksimard 

Have you guys seen any progress on this issue. Just tried setting up a test and I’m experiencing the same thing. 

Everything looks good on zapier’s end, successful test, but nothing showing in FB test events.

 

Nada. No updates, unfortunately. 

Hey guys, 

 

Any update on this issue ? 

 

I have exactly the same problem, everything seems good on Zapier’s end but nothing comes up when testing on the events manager.

Hi guys,

 

I just contacted FB support team and they said they have a CAPI bug on their side. Not very sure about the details. But, you can check with the FB support team.

 

Also, could someone help me with a question?

Is setting up Facebook CAPI with Zapier the same as setting up CAPI on Facebook with the help of a developer?

Thanks!

Hi guys,

 

I just contacted FB support team and they said they have a CAPI bug on their side. Not very sure about the details. But, you can check with the FB support team.

 

Also, could someone help me with a question?

Is setting up Facebook CAPI with Zapier the same as setting up CAPI on Facebook with the help of a developer?

Thanks!

Yes definitely, Zapier simply makes it easier to implement

@phillipadsmith  @nicksimard 

Any updates?

Same situation here.  

I have entered the test event code correctly. And on FB side pixel test event side, it doesn’t receive anything. 

Everything good on the Zapier side, but the facebook Conversion API doesn't seem to receive anything.

 

 

Userlevel 5
Badge +8

Hey @jowett,

I’m so sorry you’re running into this issue as well. I’ve done some checking on this end and we don’t have any updates on the bug report at the moment. I’ve added you to the list of affected users so that we can email you as soon as it’s resolved.

We’ll also post an update on the thread here once we’ve got word that it’s been fixed! :)

Any updates? 17 days pass..

Userlevel 5
Badge +8

Hey @alter, welcome to the Community! :)

We’ve not got any updates on this at the moment unfortunately. In the meantime, I’ve added you to the list of affected users so that we can notify you by email the moment it’s fixed!

Eager for this to start working again. Please add me to the notification of updates.

Getting this exact scenario:
 

Success message, no errors - but no events in FB

Userlevel 5
Badge +8

Hey @CIA-Zapier, I’m so sorry that you’re running into this issue too!

I’ve added you to the list of affected users now. We’ll be in touch by email as soon as it’s resolved. :)

Me too please - same situation as above. All looks good in Zapier, but no updates in Facebook Ads Manager.

I got the same problem! Please add me to the list of affected users and please fix it right now because this is a big issue that impacts a lot on all, it’s a disaster!

Userlevel 5
Badge +8

Hi @Detox Goddess and @riccardolore, welcome to the Community! :)

I’ve added you both to the list of affected users which helps to increase its priority. Still no updates to share on this right now but we’ll email you as soon as it’s been fixed!

Reply