Question

Not able to refresh access_token - Zoho Sprints

  • 16 November 2020
  • 9 replies
  • 349 views

Hi team,

 

We are using RefreshTokenException() method to refresh the access_token. Before it was worked fine. Few of customer are facing issue. When we check bundle logs. we got this error 

ERROR\tInvoke Error\t{\"errorType\":\"RefreshTokenException\",\"errorMessage\":\"\",\"name\":\"RefreshTokenException\",\"message\":\"\",\"stack\":[\"RefreshTokenException\",\"    at reinitRefreshToken (eval at module.exports.handler (/var/task/lambda-handlers/evalbox.js:14:3), <anonymous>:51:17)\",\"    at Object.get_teams_post_poll (eval at module.exports.handler (/var/task/lambda-handlers/evalbox.js:14:3), <anonymous>:490:9)\",\"    at Object.ctx.to_be_ran (eval at module.exports.handler (/var/task/lambda-handlers/evalbox.js:14:3), <anonymous>:541:69)\",\"    at Object.ctx.always_async (eval at module.exports.handler (/var/task/lambda-handlers/evalbox.js:14:3), <anonymous>:543:19)\",\"    at Function.<anonymous> (/var/task/lambda-handlers/evalbox.js:22:26)\",\"    at /var/task/node_modules/synchronize/sync.js:296:10\"]}

We couldn’t able to figure out the issue. Can you check on this team? Anything else we need to do to fix this?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +12

Hi @ZohoProjects - When you want to trigger refreshing the access token, you should do it like so:

throw new z.errors.RefreshAuthError();

I hope this is helpful to you!

Hi @ikbelkirasan Thanks for the quick response. Above mentioned method is not defined.

But, we have two apps Zoho Projects and Zoho Sprints which is integrated with Old legacy app builder. 

In Zoho Projects we are using RefreshTokenException() this method which is working fine. But, Zoho Sprints which worked before and any reason it is not working in sprints?

Userlevel 7
Badge +12

@ZohoProjects - Oh I didn’t know it was built with the legacy app builder. I went ahead and did some research and it seems that both RefreshAuthError and RefreshTokenException are basically the same error. I’m not sure why it’s not working for you though.

@Zane might be able to offer some insight. Thanks in advance for any assistance you can provide!

Userlevel 7
Badge +9

Sorry to hear about this user impacting error.  I’m going to suggest opening a ticket with partners@zapier.com.  I think to get to the bottom of this one we’ll need to tuck into your logs.  And there we’ll be in the best position to track the issue and to escalate a bug if this reveals one.

@Zane We have already mailed on last friday. Waiting for the response.

Userlevel 7
Badge +9

I’m not finding your ticket in the queue.  If you DM me the ticket number or URL from your email with team I’ll look in on it.

 

UPDATE: I found the ticket and will check in with the developer looking at it.

Hi @Zane Thanks for the update. We’re awaiting for the solution to solve this problem.

Hi @Zane @Zapier , Our Customer are waiting for the fix. Their entire zaps are no longer working because of this issue. Can you look into it at high priority?. We are waiting for the response.

Userlevel 7
Badge +11

Hi @ZohoProjects!

I’ve found the ticket in question and I see a response from our team about 4 hours ago. You can continue the conversation there so we can get this resolved as quickly ass possible. Thanks!