Best answer

"Needs a successful task" warning prevents publishing App even though we created Zaps and tested

  • 2 August 2021
  • 6 replies
  • 699 views

Userlevel 1

Hello Zapier community,

I saw an other discussion with the same topic but is has been closed a year ago.

We finished to develop an app on zapier developer platform and tested it like you can see in the image below:

We tested each trigger and action, creating zaps and turning them on but when I try to validate the apps, I have several warning saying that “Needs a successful task" or for example “Need to verify date/time format, but doesn't have a successful task”.

An other error we get is related to a “Search” action: we cannot put it live but the platform continue to ask that the zap must be live.

We cannot publish the app even if all zaps work fine. 

Did some of you had the same problem? Can someone help me?

Thanks

Giuseppe

icon

Best answer by Zane 3 August 2021, 23:54

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +9

Yes, there must be an action step after a search, otherwise the Zap Editor won’t enable it. The only reason to do a search is to look up a bit of data to use in subsequent action steps. If there’s no step configured to do something with that data, the editor is letting you know that you’re not quite finished setting up. 

If you’re unable to set up multi step Zaps because you are not on paid plan, you might reach out to partners@zapier.com and inquire about trial extension. It sounds like you’re planning on publishing this integration and, if so, you’re going to want to be able to fully exercise Zaps with your integration so that you can thoroughly test changes and support your users with trouble shooting on an ongoing basis. You might also ask partner support if there are discounts available to you once published in the App Directory. 

Userlevel 7
Badge +9

Sounds like you’ve got your search built, created a Zap to test it, it runs, but the Zap doesn’t stay on? Does that sound accurate?

When Zapier encounters too many errors in a given Zap it disables it. Perhaps that’s what’s going on here. Hypothesis: In your search, if you don’t find any matches, so you return an empty array? If you’re throwing an error in that case it looks abnormal to Zapier and the Zap gets shut down - maybe that’s what’s going on.

Suggestion - Confirm that you’re handing not found by returning an empty array. If that doesn’t get you up and running please post some detail about that test Zap - the task history, and any logs from the developer UI monitoring section.

Userlevel 7
Badge +9

> creating zaps and turning them on

You’ll actually need to go one step further. You’ll need to make sure each trigger and action runs successfully at least once, generating an entry in task history that can be inspected/validated. You’ll see these here https://zapier.com/app/history after your test Zap runs. With that, we’ll be able to help spot potential runtime issues based on end-to-end data, and you’ll be able to submit for publishing once completed. 

 >“Search” action: we cannot put it live

Can you expand on this issue? When you say you can’t put it live, do you mean you can’t use it in a Zap? 

Userlevel 1

Hello @Zane,
thanks for your reply. I understand now the point one and I already successfully validated a couple of actions that were pending.

About the Search action: we have Find Customer action that is a search one, with two input field (name and email). If I test adding a name, email or both already in databese, the zap works successful but I cannot turn it on.   I tested it using for Zapier Schedule as trigger, but the turn on toggle is disabled.

Find Customer action is a search one, with two input field (name and email). If I test adding a name or email or both already in databese, the zap works successful but I cannot turn it on. 

Although it is disabled, I still see the warning saying that a successful task is needed in the history.

 

Can you help me on this? Tell me if I need to share more info.

Thanks in advance
Giuseppe

Userlevel 1

Hello @Zane,
the zap works fine. I’m able to search a customer using his name or email and also in the developer platform, if I run a test, it goes successful and get all information:

 

 

The only error I see when creating a zap is this, even if I don’t understand what is referring to:

Can this problem be related to the fact that we must add an other action after the Find Customer one? But what if I don’t have a plan, should I buy a subscription to validate the app?

In our Monitoring section there are no errors or warnings related to this zap.
Let me know if I can provide you with more information and thanks again.

Giuseppe

Userlevel 1

Hello @Zane,

thank you very much, your help was essential.