"Needs a successful task" warning prevents publishing App even though I created Zap and tested

  • 17 June 2020
  • 6 replies

  • Anonymous
  • 0 replies

Hi Zapier team,


I saw that a few other developers ran into the same problem. I created an App and wanted to publish it now. I tested and it + created at least 5 Zaps, nevertheless it shows me the following warnings in the side menu and prevents me from publishing. Could you please resolve this also for my account or help me here?



I know this whole error validation is important for you to keep the quality of submissions high, but honestly from a developer experience this was pretty annoying since the validation was very buggy and didn’t properly work even when I fixed some of the bugs. You should probably look into this again with a product manager how to improve the experience here. Though I did like the Go to trigger feature.




This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

Hi @mathias - Is this still a persisting issue for you? We’re asking to verify with the team to see if this is resolved or still an open issue for you. Thank you!

Userlevel 1

I’m having the same issue as well. Have you found a solution?

@steph.n Yes the problem still persists. It’s incredibly frustrating since I have a finished Zapier application but can’t launch. I tested it multiple times, but it still doesn’t show me on the dashboard or with a checkmark on the screenshot below. I created already at least 3-4 Zaps for each Trigger. Even weirder that it worked for one Trigger but not for the other.



Userlevel 7
Badge +12

Hi @mathias and @whiteca, it looks like there aren’t any known issues around this right now, so I’m passing your question on to the Support Team so that they can take a closer look. 


I’ve sent you an email asking for some more information, please could you reply to that and the Support Team will pick things up from there. 

Userlevel 1

Here is a link to our Zap:


It has multiple warnings that we can not resolve. Any help would be greatly appreciated!

Userlevel 7
Badge +12

Hi @whiteca - if you could please reply to the email that I sent with that information, that would be great. That way the Support Team will have the information that they need to help :)