Best answer

Paypal Webhook is not receiving the data.

Userlevel 1

I tried to send the data to webhook but it not recieving the data. But I’ve one more account with same zapier setup and it works there. Is there anyone knows the actual reason behind this? I am sharing the screenshots of bot zaps. Let me know if anyone has solution to this issue.


  1. Zapier Account 1
  1. Zapier Account 2


Please let me know the reason behined the difference in the interface of both these zapier account.


Best answer by Danvers 1 June 2022, 12:34

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @meenakshichoudhary 

Good question.

Please reference this PayPal help article:

Userlevel 1

Hi @Troy Tessalone I made the same setup. My issue is that zapier is not fetching the new transaction details. When I go for a live transaction it got stuck in paypal IPN transaction list but not recieved by the Zapier. Please help me with it.

I need to resend the transactions again to move into zapier. Please go with the screenshots.



Please help me with delay issue.

Userlevel 7
Badge +12

Hi @meenakshichoudhary!

You said that you set up your Zap as the help guide suggests (great!) but I just want to check a couple of things that some users miss. 

In your PayPal IPN settings, make sure that it’s set to ‘Receive IPN messages (Enabled)’: 



Also, a common problem is that your notification_url is set at the button level which overrides the IPN you set in your PayPal settings. If that’s the case, you can do one of the following:

  1. Remove the notification_url setting entirely from your button and let the PayPal settings be the default.
  2. Change the notification_url in your code to the Zapier IPN hook URL from Step 1 of your Zap.


If you’ve checked both of those and are still having trouble with your Zap, it may be best to send a ticket to the Zapier Support Team using the Get help form: They will be able to check the logs of your Zap to see if there are any issues that we can’t see from your screenshots. Thanks!

Userlevel 1

So, you want to say that if I want to get the transaction notifications then I should select Do no receive IPN messages?

Hi! Having the same problem @meenakshichoudhary . 

If I set it as “Do not receive IPN messages” I get an email error saying that the hook is not receiving the messages (and no data catching) @Danvers



Userlevel 7
Badge +12

@meenakshichoudhary and @albadelgado I wrote the wrong thing in my previous post. It should have said to make sure that IPN messages are enabled, not disabled 🤦  I’ve edited the post to have the correct option and I’m really sorry for the confusion that must’ve caused!