HubSpot Error: Property values were not valid

  • 26 April 2023
  • 5 replies

Userlevel 2
Badge +1

I’m using code by Zapier to convert values from one system to HubSpot. As a result in the Code by Zapier step it returns a list value HubSpot_PracticeGroup. If there are values there they will show, otherwise it will be in the list of “Fields with no value:” when I map this field to HubSpot I get the error as shown when it runs. It doesn’t matter if the placeholder is null or empty.

I checked to make sure there are no spaces in the HubSpot field as those can throw it off as well. This is also using the most up-to-date HubSpot version. 

In the common problems with HubSpot, this appears to happen when creating a new contact which I am doing, but there doesn’t appear to be a way to exclude blank or null properties. I’m at a loss and would like some guidance. 

5 replies

Userlevel 7
Badge +6

Hey there @Arment,

Before we dig deeper into this, could you please share a detailed screenshot with how your Zap is configured? Especially, the “Action” section of the HubSpot step. Please don’t include/blur out any personal information in the screenshot.

Thanks! 😊

Userlevel 2
Badge +1

Hi @ken.a,

Thanks for the quick response! Below are screenshots of all the fields in the HubSpot action step.  I’m only including ones that have a value associated with them. 


Note here, the 3. Hub Spot Practice Group property does not have a value when testing the step. HubSpot should ignore it.

The Zap is comprised of 10 steps so if you need more let me know. I included steps 2 and 3 below to show the values returned. 


Userlevel 2
Badge +1

In addition, here are screenshots of step 3 and step 9 with the HubSpot practice group showing no value. 


If I remove the practice_group mapping it runs successfully, no problems.


Userlevel 7
Badge +11

Thanks for sharing those helpful screenshots, @Arment!

It looks like there might be an issue with the Hub Spot Practice Group field that’s been selected. Was it renamed since it was selected perhaps? I just did a test in one of my Zaps with a field that didn’t exist and one that did, and the field that didn’t exist is appearing in the same way that the Hub Spot Practice Group field is:


As you can see, there’s the same yellow background and (!) shown:

Can you try reselecting the Hub Spot Practice Group field from the Code step to see if that gets it to appear correctly? That should then allow the Zap to not pass any value to the field, instead of passing the name of the field in those curly “{{}}” brackets.

Let us know how that goes!

Userlevel 2
Badge +1

Hi @SamB,

Unfortunately I get the same result as listed above. Hubspot still provides the same error regardless if there is a null value or if the field doesn’t exist, quite the conundrum.

How does the HubSpot app handle list arrays in the code? If there is a null or empty value it shouldn’t be included on the list is that right? Looking at the image above and the error that follows its like an empty string in the first array is passed through with the error message cutting out the value that was entered in.

Typically if a value is present that isn’t an option in HubSpot it would display “{value} was not one of the allowed options:”