Zaps not working when published - no error messages

  • 9 February 2024
  • 5 replies

I had two zaps that would send an email out when a new Square space form was submitted. 

They were working fine, but then I had to update the API in Square space and as a result I re-authenticated it in my Zaps. 

In the editor, the test zap option works great and the zap does what its supposed to do, however when I publish the Zap, it does nothing. When I submit a form on the Square space site, the data doesnt even seem to be going to the Zap, as the Zap history shows not failed attempts. 

I changed nothing else in the Zap, not sure why it does’t work anymore. I even tried re-creating the zap from scratch but that did not work either. 

Anyone have any other suggestions? 


Below are some screenshots for of how the Zap is setup:


5 replies

Userlevel 7
Badge +14

Hi @ashleymenezes 

You may have to disconnect the forms in Squarespace, then edit the Zap to reconfigure the Zap trigger step.

Help articles for using Squarespace in Zaps:

Hi Troy, 

Thanks for getting back to me, 

I disconnected the connection in squareapce. Deleted my API Keys, created a new API key and tried again in Zapier and still not luck! 

Anything else I can try? 

Userlevel 7
Badge +14


Have you retested submitting the Squarespace Form?

@Troy Tessalone 

Yes I have. I get the forms submission emails from Squarespace directly, but the zap still doesn't work. 

Userlevel 7
Badge +14


From experience Squarespace can be a bit tricky to get working correctly in Zaps.


If you nee help, consider hiring a Certified Zapier Expert: