Zap isn't picking up all fields from Pipefy "New Database Record" when adding a row to Microsoft Excel.

I am attempting to integrate pipefy with excel using zapier. I want to add new entries from my database in pipefy  to a new row in excel. 

Here is my database

and here is my zap

As you can see zapier does not pick up any data from the name, salary, and email fields in my database, only the title field. Can anyone help me?

3 replies

Userlevel 7
Badge +14

Hi @jorden.monroe 

Good question.

Zap trigger is Pipefy - New Database Record.

That triggers when a new record is created.

Are all the data points populated when the record is created in Pipefy?


Help article about how to change the Zap trigger data:


Have you tried turning the Zap ON and testing live?

Then check your Zap Runs history details to see the DATA IN/OUT for each Zap step.


I turned it on and it only updates with the “title” value. 

When I get to the test portion of the pipefy trigger I can see the values that I need 





But when I get to the Action portion where it asks me to insert the data the data that I need is not available..





I have tried every option as input, none of them have the isolated values for Email, Name, or Salary. Some contain every field value in a list but that is no good to me. 

Userlevel 7
Badge +14


It looks like Pipefy is returning all the data points for the record as an array of objects.

Advanced data handling is need to match the Name to the Value so you can then map the desired data point individually.

This will involve the use of custom Code:


If you need help, consider hiring a Certified Zapier Expert: