Best answer

YouTube error: The app returned "Media type 'text/html; charset=utf-8' is not supported."

  • 19 November 2021
  • 4 replies
  • 287 views

Userlevel 1

 

I am copying video from one youtube channel to the other one , i have setup the below settings , do not know why i am getting this error 

 

The upload video could not be sent to YouTube.

The app returned "Media type 'text/html; charset=utf-8' is not supported.".
 

 

 

This post has been edited by a moderator to remove explicit content. Please remember this is a public forum and any inappropriate content is prohibited. 

icon

Best answer by SamB 19 January 2022, 12:43

View original

4 replies

Userlevel 7
Badge +14

Hi @jamesworld 

This is the URL of the page that has the video, which is different than a link to the video file.

 

Help article about using files in Zaps: https://zapier.com/help/create/basics/send-files-in-zaps

 

Is there a different data point that you can try to map that is the video file url?

Userlevel 1

did not understand what you are saying , can you please tell me what to add and where to via screenshot or by text , in simpal words 

Userlevel 7
Badge +14

@jamesworld 

Copy and paste the URL you currently have mapped to the Video field, into a browser to see what renders.

That will take you to the webpage that has the Youtube video embedded, which is not a link to only the video file.

You need to map a link to the publicly hosted video file, not a link to a webpage.

Userlevel 7
Badge +11

Just wanted to pop in here to note that the YouTube integration doesn’t currently supply a file object or publicly accessible link to the actual video file. This would be necessary in order to upload the video (Send files in Zaps).

We do have an existing feature request for the video file to be supplied with YouTube integration triggers so I’ve added @jamesworld’s vote for that. I don’t have any estimates to share on when that would be implemented but we’ll be sure to reach out via email once it is! :) 

Reply