Best answer

YouCanBook.Me error: We couldn't find any more bookings. Create a new booking in your account and try again.

  • 27 April 2023
  • 6 replies
  • 97 views

Userlevel 2
Badge +1

I have a Youcanbook.me booking page with a zap that creates an event whenever a new booking is made.

The event is getting created without a problem.

However, as soon as I go on the Zap, and try to load the bookings in the “Test” section, none of the new bookings appear except two very old bookings, and I get the following message: 

We couldn't find any more bookings. Create a new booking in your account and try again.

 

This is causing me a headache to be able to test out new features.

 

 

icon

Best answer by xavierB 28 April 2023, 12:16

View original

6 replies

Userlevel 7
Badge +6

Hey there @xavierB,

May I ask if the connection was set up according to
https://support.youcanbook.me/article/71-integrating-zapier-with-your-youcanbook-me-account?

I also found some troubleshooting steps here (under "I can't get sample data into Zapier")
https://support.youcanbook.me/article/208-what-do-i-do-if-my-zaps-arent-working

Could you please try the steps there? 

If that doesn't work, would you be able to

  1. create a new Zap with a New Booking in YouCanBook.Me trigger
  2. ensure you select the correct Profile
  3. try to pull in some samples
  4. try the steps in the documentation above again

Please keep us posted! 😊

Userlevel 2
Badge +1

Hello,

Thank you for the prompt response. Indeed, I have tried creating a new zap with a new trigger but still with no success. It’s weird because the actual trigger is working in normal conditions, just not when pulling test data.

I think the issue may indeed be this 5 minute buffer - is this something on YCBM’s side? It’s making the whole testing process extremely complicated.

Kind regards

Userlevel 7
Badge +6

Hi @xavierB,

This seems like a weird behavior from the trigger. One potential solution to this issue would be to try reconnecting your account, as this may resolve the problem. You can reconnect your YouCanBook.Me account by visiting this link: https://zapier.com/app/connections/youcanbookme

In addition, I suggest checking out the help articles that I linked in my previous response from YouCanBook.Me. These articles may provide additional guidance on resolving the issue you're encountering.

Here are the links to the articles again:

Let us know if these solutions help to resolve the issue.

Thanks! 😊

Userlevel 2
Badge +1

I’ve tried reconnecting my account, and I have updated my API key numerous times. This does not seem the be the cause of the issue.

Userlevel 2
Badge +1

Ok with further testing, it seems that you can fetch some data when a booking has been made very recently (less than 15-20 minutes I reckon). Once that time-limit is done, you cannot fetch the test data.

Seems like a bug, but the workaround is to make a test-booking and immediately come on Zapier to test it, without expecting to be able to retrieve the data if you wait too long.

Userlevel 7
Badge +6

Hi there @xavierB,

Glad to know you were able to get it sorted! Just a little bit of context on the issue you’re running to I found this similar issue on our notes, and it seems this is a limitation within the webhook of YouCanBook.Me integration:

YouCanBook.Me batches up their sending of webhooks to a run about every five minutes-twenty minutes. So if a user is trying to setup a Zap and not receiving the hook quickly, have them wait and test just before a 5-20 minute mark and it should come through.

 

Reply