Best answer

Why is Zapier adding a timestamp to my dates?


Zapier seems to be adding a timestamp and timzone to my date output and not matter what I have tried, nothing seems to be fixing the issue. 

I have tried using a formatter but it does nothing. The date doesn’t come in with a timestamp so i dont know why it’s outputting with one. 

icon

Best answer by Jess.Altimus 20 June 2023, 18:02

View original

7 replies

Userlevel 7
Badge +11

Hi @Jess.Altimus!

Could you provide some more details about how your Zap is set up? Ideally, some screenshots would be helpful as well.

We’d like to see what your trigger is (which app it’s coming from), where you’re mapping data (which app is receiving the data), and which field is adding the timestamp and timezone.

Thanks!

Yes certainly

 

I’m pulling information in from Typeform and sending it to constant contact. The date comes in from Typeform in a DD-MM-YYYY format. 

 

I am running it through the formatter to change it to MM-DD-YYY Y format and the output is showing correctly.

 

Then I have it finding or creating a contact in Constant Contact and/or updating a contact. Both have a final output as follows: 

 

 

I’ve also tried this not using the formatter and pulling in from a google sheet instead of Typeform and the result is always the same. 

Userlevel 7
Badge +14

Hi @Jess.Altimus 

The Policy Start Date field is a date/time field as indicated by the 2 icons.

So a date will be converted to a date/time format.

Everything after the T is the time.

00:00:00 indicates midnight and that the value was input just as a date.

The -05:00 is the time zone offset.

 

Thank you Troy, 

 

As noted in my original post, I am aware that the format is a timestamp and timezone. My question is, how do I remove that when the formatter does not seem to be doing the trick? 

Userlevel 7
Badge +14

@Jess.Altimus 

The Constant Contact app, where you are sending the date value is converting it to a timestamp.

 

@Jess.Altimus

The Constant Contact app, where you are sending the date value is converting it to a timestamp.

 

Thank you. I don’t know why that started all of the sudden, i have never had this issue in the past. 

I changed the field settings in Constant Contact to be a text field instead of a date and that did the trick. 

Userlevel 7
Badge +9

Yay! Glad to hear you were able to get sorted! Thanks for keeping the thread updated with your solution. 🙂

Reply