Question

Using Date/time transform in Templates cannot TEST action and use outcome in template

  • 19 October 2022
  • 4 replies
  • 39 views

Good day,

 

I am creating ZAP templates for our app, one of the templates needs some Date/time formatting in between steps. I used the Send Date/time Transform to Formatter by Zapier (1.0.3) to try and create a time formatter. 

This works well in a normal ZAP, but I cannot get it to work in a template, because there is no sample data in a template.

The problem is - I cannot go beyond that step without the test running, my templates now has an error - because there is no sample data found.

As a result, I cannot use the outcome in the following step, and cannot then publish the template.

 

How can I use a Formatter in a ZAP template? is there something I am missing here? This is where I get stuck, pressing the “test” button just hangs and if I skip the test, I cant get the outcome of this step to use in the subsequent step. How to get around this?

 

 


4 replies

Userlevel 7
Badge +9

Hey @digitalpractice! I have seen errors like this in the past when the “To Format” field is filled out but the “From” format isn’t. Mind giving that a try to see if it helps? If not, and you’re on the current version as @MohSwellam suggests, then contacting our support team will likely be the next best step in getting this one resolved: https://zapier.com/app/get-help

Userlevel 7
Badge +8

Hi @digitalpractice 

 

I believe its a problem with the version (since I dont have a version number beside it, which probably means this is an older version of the formatter). I tested the exact same data on my side and it worked without a problem. Maybe remove this step and recreate it with the newest Formatter version? 

Thank you for the response, but this does not resolve my problem.

My challenge is on the “Zapier Templates side” not ZAP, I can run the exact same ZAP without a problem, because in the ZAP the data is there. But I am trying to create a Template.

I even entered the data manually in the template like so:

 

But still get the error - sample not found.

 

The test just hangs, even with a manual date entered, see image:

 

This only happens with the Zapier Date/time Formatter, any other block works fine in the template. 

Userlevel 7
Badge +8

Hi @digitalpractice , 

 

If I understand you correctly, you want to map an empty field. I have posted a tutorial earlier just for that case

 

 

Hope this helps :) 

Reply