Unable to post to Facebook group due to Zapier access issues (#200)

  • 20 November 2023
  • 8 replies

Userlevel 1

I setup my Zap and it looks all fine and well until i try to test it and it’s coming back as failed with below error message. I have made sure my connection to facebook is active ( but this looks like some sort of issue where Facebook is not communicating to Zapier that it has access to my group.

I tried to go into my group (i’m admin) to try remove and re-add Zapier as an “app” but i can’t see anywhere to do that anymore. In facebook ( when i select my group on left side, I only have “...” three dots context menu on top left → “group apps” → it just lists “Buffer” with full access and “Zapier” with “Apps You Can Allow Access” but there’s no button or option to enable access? I don’t even see on facebook group settings the area to even add a new app anymore? Has facebook changed the way external apps access and therefore zapier / facebook doesn’t work anymore?


when i try reconnect zapier account in the zap setup, it shows logging in but now it only asks for page access (not groups?). Something seems off with Zapier losing access to groups? This is the last picture below. Please help


Failed to create a post message in Facebook Groups
(#200) If posting to a group, requires app being installed in the group, and \ either publish_to_groups permission with user token, or both pages_read_engagement \ and pages_manage_posts permission with page token; If posting to a page, \ requires both pages_read_engagement and pages_manage_posts as an admin with \ sufficient administrative permission. Please check the settings within the Facebook Group, and verify that the Zapier application is enabled. You can learn more here:






8 replies

Userlevel 1

Hello, I too have the same problem since yesterday. Thanks

I don't understand yet it has been working correctly for 4 months. I reconnected to the Facebook group but nothing happened.

Hello, I also have the same problem since Saturday 18/11, disconnected and reconnected the app but it doesn't work anymore

Userlevel 1

Same problem here

Userlevel 1

Still no solution ?

Userlevel 7
Badge +6

Hi friends,

There might be some kind of caching issue on Facebook's end that is preventing this from happening. Let's try to take the following steps:

  1. Click on the following link once logged into your Zapier account:

  2. Delete the connection:
    (view larger)

  3. Open the Facebook Group and go into the settings:
    (view larger)

  4. Click on the pencil

  5. Remove all FB Group Apps

  6. Then click on "Add Apps" and select Zapier > provide the permissions and allow access:
    (view larger)
    (view larger)
    (view larger)

  7. Check the "Post content into this group on your behalf" checkbox to give permissions:

    alt text

  8. Add a new connection within the Zap you're working on.

Userlevel 1

Thank you for your help, I did a test, it works again.

Userlevel 7
Badge +6

That’s great news @Ced33fr! I’m glad to hear that I was able to help!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 😊

Userlevel 1

Thank you, yes it is working again :)