Question

Transfer “Missing a secondary auth” error

  • 24 March 2023
  • 4 replies
  • 43 views

Userlevel 1

Hi, 

I want to use Transfer to bulk transfer items from my gmail to my company account. I am getting a secutiy error for multi Factor Auth - I think. This is actually a proof of concept for one of my colleagues.

Here’s the error. 

 

There was a problem fetching your Transfer

Missing a secondary auth for `DataFlowApp(account_id=14855896, auth_identifier='<xxxx>', selected_api='MicrosoftOutlookCLIAPI@1.11.0')`

 

The xxxx is my email address

I have mfa on both accounts. without disabling it how do I resolve this? 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +12

Hi @antihippy!

Hmm, you’re right; this is a head-scratcher. 

There’s one last thing I’d suggest before reaching out to the Support team, re-authorize Gmail and Outlook in My Apps. Go to My Apps and reconnect both apps and see if that clears up the issue. 

If not, I recommend reaching out to the Support Team (using the Get Help form), so they can take a closer look at this with you. 

Userlevel 7
Badge +11

Hey there @antihippy! 👋

We sometimes see that error when we’re connecting Gmail with an app that isn’t a Google-approved app or one that needs to be re-authorized. It looks like Microsoft Outlook is one of the approved apps listed (here: My Gmail Zap has an error about connecting to Google-approved or not-approved apps) so it should just need to be reauthorized to create the secondary auth.

Was there any additional details in the error message? Usually there’s a part at the end that says “Fix: Visit this URL to connect your accounts:” which is followed by a link that you’ll need to click in order to set up the necessary secondary auth to allow Microsoft Outlook to work with Gmail in your Zaps. 

Can you take a look for that and let us know whether you’re able to find it and get that secondary auth set up?

Userlevel 1

Hi @SamB , 

I’m not seeing any link to reauthorise. Both accounts get the green tick and when I review the records to transfer Transfer is able to access the records I want. 

I’ve even gone back and edited the Transfer and started again - same issue. Bit of a head scratcher. 
 

 

Userlevel 1

Reading your reponse and looking at this error - it looks like it’s transferring my gmail account details to Outlook? 

Btw the this outlook account is a M365 E5 account and I am the global admin. And yes I have already authorised zapier in my organisation.