Best answer

"This content can't be displayed" in text field

  • 20 December 2022
  • 3 replies

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.



I am getting the next error “This content can't be displayed.” in the text field.



When the text is this:


Do you know what it is happening?, and how can I resolve it?.


Thanks a lot!


Best answer by SamB 4 January 2023, 18:01

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 6
Badge +8

Hi @leidymgdev,

I’ve never seen anything like that. I can tell you that that message (“This content can’t be displayed”) was actually getting sent to use from Slack in the text field.

I don’t know why Slack sent that as the text if it wasn’t the actual text of the message. It looks like maybe this happens when a bot sends the message.

It looks like in the last couple of Zap Runs for you you’re now getting an actual message instead of “This content can’t be displayed.” Did you change something that fixed it?

I am getting the same error “This content can’t be displayed” and I noticed that to someone happens the same 

This is the a message posted by a bot in a slack channel, I need to take this information to move it in another slack channel.


This is the info moved in another channel, the content is wrong because it shows “This content can’t be displayed” and not more.


This is the first step in my zap:



And this is the other step that indicates which information is going to take and move to the a another channel and you can see that in the editor zap the Text and Raw Field says “This content can’t be displayed”.


Do you know that do I have to do to fix it?, thanks a lot!

Userlevel 7
Badge +11

Hey @leidymgdev

Ah, it seems like the text posted by the bot is likely in a “block” so is that’s why the Zap getting the same “This content be displayed” message coming through.

Looks like we’ve already added your vote to the feature request mentioned on that related topic you found. So we’ll be able to notify you as soon as it’s implemented.

If we’ve got any updates on it in the meantime we’ll be sure to post them on the main topic here:

Fingers crossed it’ll be sorted soon though! 🤞