Best answer

Test trigger only pulls in one single event from 4 years ago.

  • 10 January 2023
  • 5 replies
  • 263 views

I've tried everything from turning zap on, off, backwards, forwards, upside down, recreated the zap, click load more option after multiple different sets of steps, reconnected the programs, you name it!

This is affecting me with multiple programs including Setmore, Lead Connector, & others.

Not sure what I could be missing if someone could help me! TIA!

FYI I saw another thread on this exact topic here - https://community.zapier.com/how-do-i-3/test-trigger-only-showing-old-orders-18299 - for some reason the thread has been closed with no answer.

icon

Best answer by christina.d 16 March 2023, 02:04

View original

5 replies

Userlevel 7
Badge +14

Hi @lbm 

Good question.

Have you tried testing the event in the source app, then trying to pull thru that data in the Zap trigger step: https://help.zapier.com/hc/en-us/articles/8496310366093

Hi @lbm 

Good question.

Have you tried testing the event in the source app, then trying to pull thru that data in the Zap trigger step: https://help.zapier.com/hc/en-us/articles/8496310366093

 

Hi @Troy Tessalone ! Thankyou for the quick response! 

So far I have created multiple test events at multiple different stages of the zap setup. 

Some of the things I have tried include:

 

  1. Create zap
  2. Configure with old record
  3. Publish zap
  4. Test zap sends to destination app > successful
  5. Create test event in source app
  6. Edit zap > test trigger > load more > no new event

 

  1. Create zap
    1. Without publishing zap at all, and
    2. After publishing then turning off again and going into edit mode
  2. Enter test event > go to zap edit > test trigger > load more > no new event

 

  1. Enter test event in source app
  2. Create new zap > test trigger > load more > no new event

Then I’ve been through these again after reconnecting programs etc. 

The zap DOES work when published, in that the events are pulled from the source app to dest app correctly.

It is the test function that won’t seem to load any new data making it hard to configure for different combinations! Thanks again!
 

 

Userlevel 7
Badge +14

@lbm 

I recommend opening a ticket with Zapier Support for further help: https://zapier.com/app/get-help

 

Since most Zaps are configured by the app developer, rather than by Zapier, I’ve noticed some Zap app triggers don’t behave ideally.

  1. Some Zap triggers only provide an example with dummy data so you can configure the Zap action step(s)
  2. Some Zap triggers only provide old examples with real data.
  3. Some Zap triggers provide fresh examples with real data. (this is ideal)
Userlevel 7
Badge +11

Hey there @lbm!

I did some checking on our side and found that there’s a couple of feature requests open for the ability to retrieve recent appointments (Setmore Appointments) and recently changed pipelines (LeadConnector) test samples. I’ve gone ahead and added your vote for those feature requests so we can email you as soon as they are implemented in the Setmore Appointments and LeadConnector apps.

For any other similarly affected apps it may be best, as Troy suggested, to reach out to our Support team to investigate further.

In the meantime are you able to continue building your Zaps using the sample event the Zaps was able to pull in as a starting point?  

Userlevel 7
Badge +9

Hey friends! 👋🏽
Wanted to pop in and let ya’ll know recently changed pipelines for LeadConnector test samples are now supported! 🎉

Happy zapping! 🧡

Reply