Best answer

Sub-zaps not found in new Zap

  • 17 June 2022
  • 4 replies

Userlevel 1



When I try to call a sub-zap in a new zap, the list of sub-zaps is empty, although I have 6 sub-zaps in my account, I can not select any. 



I have plenty of sub-zaps in my home folder (see screenshot). They worked fine until now. 



I understand this is still in beta, so maybe this is a bug? 

Thanks in advance for your help,




Best answer by Danvers 20 July 2022, 12:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 1

Ok, I think I found the problem. 


I changed an old zap into a sub-zap, this seemed to be incompatible to be used in new zaps. 


Creating a completely new sub-zap fixed the issue. 


However, I think that I cannot use any of my existing sub-zaps in new zaps? So if I wanted to I would need to recreate (copy) my old sub-zaps from scratch? Since I only see the one new sub-zap in the list, all the other ones are still not showing. 


Thanks in advance! 

Userlevel 7
Badge +12

Hi @tscheys!


I’m sorry for the trouble that you’re having selecting Sub-Zaps to use your Zap. This is known issue with Sub-Zaps that we’re looking into. 

In the meantime, some users have had success by manually typing the Zap ID in the Sub-Zap field as opposed to using the dropdown list. The Zap ID is the number that you can see in your browser’s address bar (the url) when you’re editing the Zap

nb This is a fake ID, do not share your Zap IDs in the Community

You can add it to the Sub-Zap field by selecting ‘Custom’ and then typing/pasting it into the field:


I hope that helps, let us know if it works!

I’ve also added you as an affected user on the bug report for not being able to see all Sub-Zaps in the dropdown list, so we’ll email you when we have an update. Thanks!

P.S. For anyone following along, we’ll be posting updates to the main thread we have open for this issue, here: 


Have there been any developments on this issue? Entering the Zap ID manually isn’t working for me. 


I ran into the same problem today and found a workaround that works for me. 


  1. Edit the Sub-Zap that is not being found in the list.
  2. Under the trigger step, add an entry in the Input / Argument List. What I’ve been using is “Test”
  3. Publish the Sub-Zap, copying the Sub-Zap ID from its URL.
  4. Return to Zap that references the Sub-Zap and
  5. For the “Select Your Sub-Zap” option, choose to enter a Custom Value instead of using the dropdown.
  6. paste the Sub-Zap ID


That worked for me. updating the Sub-Zap Input / Argument List and Publishing seems to at least prompt zapier to find it via the custom field. 


If you need clarity, let me know what I can help with. I’ve attached a couple of images to help.