Question

Stripe trigger doesn't return Customer's name and email

  • 2 April 2023
  • 5 replies
  • 177 views

Hi, 

 

I am encountering an issue with a zap I have setup with stripe/flodesk. When a purchase is made in stripe, it’s supposed to update the person’s name, and contact email within a certain email segment on flodesk. With no changes being made to the Zap it suddenly started failing. I looked through the history, and the primary reason seems to be that while the data output from Stripe does contain the needed information (name and email), it frequently isn’t showing the information in the output. Typically it’s just the email, but there were a couple instances where it was both email and name. 

 

I tried turning the zap off and on, changing where the name and email come from (doing billing info instead of customer info) but am still encountering the problem. 

 

Does anyone have any advice for this?

 

Thanks!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 3
Badge +4

Hi @themodernminimalist 

Welcome to the Community!

Could you kindly send a screenshot of one Zap run with an error? This would allow me to check further.

(If there’s any personal information, kindly blur them.)

Looking forward to your response!

Hi, 

 

Yes, here is an example of an error on one of the Zap runs. 

In this particular run, the email was input and was an iCloud email. It shows up in the customer email section, as well as the billing email section.

Thanks!

Userlevel 7
Badge +6

Hey there @themodernminimalist,

I’m jumping in to see if I can help!

Whenever you see those {{...}} curly braces around entries in the Data In of an action, this means that there is a field mapped there in the Zap Editor, but when the Zap ran live this data was not sent from a previous step.

Stripe usually returns multiple data that contain the email and name. I suggest remapping the “Email” and “First Name” fields with other data from the trigger. The data should look and contain something like “Billing Email….”

Please give that a try, and keep us posted!

Thanks! 😊

I gave that a try, and just had the zap run and it failed again. This time in the output data all the email fields say “null” as though the person didn’t enter them in, but the email is in the description section, under payment method, payment method types, balance transaction. Any additional thoughts? 

Userlevel 4
Badge +6

Hi @themodernminimalist 

The first thing I noticed on the screenshot you shared was the curly braces.

These curly braces indicate that the field mapped over from the trigger was empty or didn’t exist like it did when you set up the Zap.

In this case, it looks like the "charge__billing_details__email" field have been renamed or deleted in Stripe and therefore passed an empty value to Flodesk.

To resolve this issue, you'd want to load new test data in your Zap trigger: https://zapier.com/help/create/basics/change-the-test-data-in-your-zap-trigger, and re-map the affected field in the action step using the updated field from your trigger.

For more info on potential solutions, check out these help docs:

https://zapier.com/help/troubleshoot/errors/fix-required-field-is-empty-errors-in-zaps

https://help.zapier.com/hc/en-us/articles/8496199667981-Zap-trigger-isn-t-sending-data