Squarespace submission multi-picklist to Salesforce multi-picklist will not work

Currently have a multi select pick list in a Squarespace submission form. Not matter what combination I use for the formatter, and changing commas to colons and removing the spaces, the data will not plug into Salesforce. Is there a flaw with the system going to lightning?


8 replies

Userlevel 7
Badge +8

Hi @ArmandVioli 


As per the SF API documentation, you should in fact separate the values using a semicolon. 


In the above screenshot, it does appear that a record was created in Salesforce with the value 31-80 Pads;81-150 Pads (which is the correct way to send the data to Salesforce). What does this record show in Salesforce? Just one select with the value as a string? 

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Hey - Yeah so nothing comes up in salesforce. “Data In” like you said looks correct. “Data Out” shows that area as empty. I quadruple checked I have the spacing, capitalization and everything correct and matching but now matter what if I select one option, or multiple nothing will get input to salesforce. 


Userlevel 7
Badge +14

Hi @ArmandVioli 

Good question.

Make sure you are using the internal values expected by Salesforce for each option.

Sometimes the friendly display value is different from the internal option ID.

You can check this by looking at the list of multi-pick options, and take not of the value that is in the smaller gray font for each, as that is what Salesforce expects.

You may need to use a Formatter > Utilities > Lookup Table to translate values first.


Select more than one value from the dropdown field

If you have a multi-select pick list field in Salesforce then you can select multiple items by using semicolon character ; between them.

Alternatively if you're passing data from a previous step, you can use Formatter to create a string with ; as the separator.

@Troy Tessalone Hey yeah I triple checked both expected values and API inputs are exactly the same, literally have tried this 1000 different ways and cannot get it to input. Any other ideas?


Appreciate you and @MohSwellam help


Userlevel 7
Badge +14


Does it work with only 1 option?


Make sure there is no leading/trailing whitespace for the values.


@Troy Tessalone Yes tried that as well. No luck

Userlevel 7
Badge +14


Is there a setting on the Salesforce side that prevents those value from being set?

Userlevel 3
Badge +4

Hi @ArmandVioli 

I see that you’re already working with one of our Support Specialists. And here’s what they said,

So what I suspect is how Salesforce expected multipack lists to be shared with them. The next steps:

  • Try directly mapping (directly type into field) some picklist values separated by commas, semi-colons and test the SF step
  • Also try converting the the picklist values string above into line items and using the output instead into the SF field and retest the step

Just to confirm, have you tried these steps? If so, did any of them work?

If you’re having trouble with the steps, please continue working with our Support Specialist on this.

Thank you! 😊