Slack workflow error: Bad request to Slack found, duplicate_external_id

  • 14 June 2022
  • 8 replies

good afternoon,  I am trying to add a line to a excel sheet on my one drive.   All of the tests are working properly and I keep getting the error message: Bad request to Slack found, duplicate_external_id

ZapierAPP  5:35 PM
An error occurred executing a workflow step you own. Check out your workflow for further details.



I cannot seem to just send the data from the workflow to Excel.  I’ve tried to re-create over and over and get the same message.  I’m sure there is a error in my workflow but I just cannot seem to find it.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

I’m having the same issue! The test goes fine but I am encountering this error every time. I thought maybe I have to ALSO set up a Zap on Zapier in addition to setting up the workflow in Slack, but it hasn’t solved the issue either!

Userlevel 7
Badge +9

Thanks so much for reaching out, ya’ll.
@michaelcbarnard I know you were able to reach out to our support team and they confirmed you were working with Slack Workflow Builder. I hope you don’t mind my sharing some of the suggestions from the ticket to get us on all on the same page!

@Joshua341 is this true for you as well? If so, full transparency this can be a little tricky for our team to troubleshoot since there’s no way for us or the support team to test or rebuild in your Slack account. 😔

My friend Adi in support first recommended “...deleting the action step and see if I could rebuild it from scratch” - I wonder if that might be worth giving a shot?

Keep us posted!

This is also happening to us.

  • Have deleted the entire workflow and rebuilt from scratch multiple times.
  • Deleted the connection between Slack and Zapier.
  • Deleted the connection between Zapier and the app.

Every time I get the, “An error occurred executing a workflow step you own. Check out your workflow for further details.”

And then when I check out the workflow...there are no further details.

Userlevel 1

I have the same issue any update on this ?  

hey there! I do have the same Problem. Can you please update? 

I wonder if there is any update for this issue?

same here, any solution?

@christina.d why there are no responses for this issue yet?