Best answer

Slack error from halted execution: Nothing could be found for the search.

  • 10 August 2023
  • 3 replies

Userlevel 2
Badge +1

I am trying to find a message in Slack based on the permalink to the message but I keep getting this error:
Failed to find a message in Slack
Error from halted execution: Nothing could be found for the search.

From this Zapier Community thread it seems I should be able to do this and I had the Zap set up like this previously with no issue… has something changed?


Best answer by cpzap 11 August 2023, 00:28

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 2
Badge +1

I swear there must be some magic in posting these questions because I tried the EXACT steps I have been trying for days to get the screenshots you requested and it now miraculously works.

But to summarize what I am doing is I have a Zap that triggers on a new Slack message, parses the permalink to get the timestamp of the parent message (because the new messages I need are threaded messages), then I piece back together a link to find the parent message to extract info from the parent message to use to find a ClickUp task based on the info I extracted then post the Slack message as a ClickUp task comment.

Everything seems to be in working order now. Thank you!

Userlevel 7
Badge +14

Hi @cpzap 

Good question.

We would need to see screenshots with how you have your Zap steps configured along with the Slack Message you are trying to match.

Userlevel 7
Badge +11

That happens to me all the time, @cpzap! Thanks for following up here and for sharing the steps you tried that eventually got it working. Perhaps it was just a temporary glitch? At any rate, I’m glad it’s working now. 

If it stops working again or you run into any further issues at all just let us know. Always happy to help! 🙂