Best answer

Please tell me the date and time format for GMB that does not cause errors.

  • 8 February 2024
  • 8 replies

Userlevel 1

Hi, please tell me the date and time format for GMB that does not cause errors.

I was using “YYYY-MM-DDTHH:mm:ssZ” format, but after setting the account's timezone I started getting the error.
AI suggests using the format I'm already do.

Please let me know if there is any other way to enter date and time without errors (or if my settings are incorrect).





Best answer by ken.a 13 February 2024, 08:03

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +11

Hi there @Naoya! 🙂

I did some checking on this end but could see any specific date format requirements noted.

What error are you seeing? If possible can you share a screenshot of the full error. Hoping there might be some clue in there as to what’s wrong with the format.

That said, you mentioned that you changed the timezone. What timezone was it previously and what did you change it to? Just wondering if it might be that following the timezone change it’s expecting the day and month values to be supplied the other way around - US vs UK date format for example.

Looking forward to hearing from you on this! 

Userlevel 1


Thanks for your kind comment.

Error message is “Couldn't create a post for this location: Request contains an invalid argument.”
I also attach the AI ​​troubleshooting answers. 

I tried setting "+00:00" format AI answerd with custom setting, but error message was not changed.


Timezone of my account I set is “GMT+09:00 Asia/Tokyo”.

Before this setting,I set nothing. 
And I don’t know which Japan date format likes US or UK.


Userlevel 7
Badge +6

Hi there @Naoya,

I’m jumping in to see if I can help!

I have a hunch that the Date isn’t the culprit here. Could you please send a screenshot of the “Action” section of your Google My Business step that shows all of its fields? Like so:

(view larger)


Userlevel 1

Thank you @ken.a ,

I put screenshot your said.
And attached Result of test in screenshot.
I hope you have a good idea.


Userlevel 7
Badge +6

Thanks for the screenshot @Naoya!

It looks like the mapping is good. However, I have a little bit of concern with the typed “@” sign in the “Name of the event” field. Could you please try removing the “@” sign on that field? Like so:

(view larger)

After that, please try testing or triggering the Google My Business step again.

I'll be keeping an eye out for your response!

Userlevel 1

Thank you @ken.a ,
I tried  several values ​​in “Name of the event” field. 
Then, I found out that the error was caused by a newline code included in spreadsheet data.
Your advice led me to the correct answer. Thank you for your kind message!

Userlevel 7
Badge +6

That’s an amazing news @Naoya! I’m glad I was able to somehow point you to the right direction!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Userlevel 1

Thank you @ken.a  and @SamB ,

From today, I would be relieved of a lot of task.

As you said, if I have any problems, I will consult this community.

Thanks so much!