Question

Notion error: > Expected block type heading_1 in request body

  • 28 October 2022
  • 6 replies
  • 290 views

I am getting the following error when using the “Update Database Item in Notion” action:

> Expected block type heading_1 in request body

This doesn’t make sense and I can’t seem to fix it. Is this a known issue? I don’t see others with this same issue online. 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +9

Hey there, @Gowiem! Thanks for reaching out and sorry to hear you’re running into that error. 

Which field are you trying to update in Notion? Are you you looking to append text to the bottom of the page by chance? 🤔 If you are and it’s the content field it is possible you’re running into a known Notion bug. 😔

Let us know if that’s the case and I’ll be sure to get you added as an impacted user!

We’ll keep an eye out.

@christina.d yeah -- that sounds like the issue exactly. Can you please advise on an ETA when that will be fixed? Is the fix needed on the Notion API side or on the Zapier integration side? This issue has been going on for over a year, which is concerning and has me wondering if Zapier integrations with Notion (which is one of my primary tools) is going to hold me back from utilizing Zapier. 

Userlevel 7
Badge +12

Hi @Gowiem

We don’t have an ETA for when that issue will be fixed, I’m sorry. I have added you as an affected user on the issue, which helps to add weight to its priority. 

I’m sorry that I don’t have better news for you today and thank you for sharing your feedback. 

Still no fix?

This still seems to be a bug, but there is a simple fix around it:

The bug is on the Notion end of things and is related to appending additional text to the content area of the database entry. If the content area is already blank, the zap will run fine. If there is content in that content area, the zap will fail.

The way I solved this is to edit the template for the database in Notion and add a field that you’ll be using specifically for your zap. In my case, I added a text field called Recommendations. I configured the zap to add content to Recommendations, which works nicely.

Badge

@Vernal, can you elaborate on your solution?


What do you mean you added a field for your zap? Do you mean you added a new text property called Recommendations?

I’m facing the same issue on my end.