Best answer

MailerLite error: Required field "Subscriber Group" (group_id) is missing

  • 23 March 2023
  • 6 replies
  • 81 views

Userlevel 1
Badge +1

I manage students in Airtable and email them from Mailerlite, using Zapier to connect between the two. I have two Zaps: one to add students to a Mailerlite groups, and another to remove them.

The Zap that is supposed to remove students from a group keeps triggering at the same time as the one that adds them (but it runs into an error, so thankfully no harm done: I just get an annoying amount of error emails from Zapier).

The adding zap is watching a ‘time last edited’ field; the removing zap is watching a DIFFERENT ‘time last edited’ field. I’ve checked and double-checked: the removing ‘time last edited’ field is NOT updating. I tested and retested the Zap, but when testing it (correctly) can’t find the records it triggered and errored over just minutes ago.

Any ideas?

icon

Best answer by Sigurdur130 28 March 2023, 13:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +6

Hey @Sigurdur130,

Before we dig deeper into this, could you please try reconnecting your Airtable account? Here: https://zapier.com/app/connections/airtable

After that, please try triggering the Zaps again and checking if the Zap will trigger unexpectedly after reconnecting.

Please give that a try and keep us posted!

Thanks! 😊

Userlevel 1
Badge +1

Thanks for the answer, ken.a. I’ve reconnected and triggered the ‘join course’ Zap. Usually the ‘leave course’ triggers in the next poll so I gave it 10-15 minutes, and it’s all good! Thanks for the fix ^^

I’d love to understand this: how / why did reconnecting my Airtable fix this? What did it actually change? Or is this a case of “just turn it off and then on again, it’s just magic”?

Userlevel 1
Badge +1

Neeeevermind. A new student joined and what do you know it, Zapier tried to remove them. I’m lost again. Any more ideas?

Userlevel 3
Badge +4

Hi @Sigurdur130 

Could you kindly send a screenshot of how you’ve set up the Zaps? This would allow me to check further.

(If there’s any personal information, kindly blur them.)

Looking forward to your response! 😊

Userlevel 1
Badge +1

Hey Charie, thanks for the answer! It was brought to my attention that the zap was doing exactly what it’s supposed to; I was just so focused on the fact that I had it watching a field for UPDATES, that the name of the trigger is ‘NEW OR updated record’. It was, of course, triggering on new records. I set it to watch a view and now it works exactly as it should =)

Userlevel 7
Badge +6

Hey there @Sigurdur130,

Glad to know you were able to get it sorted!

If you have any other questions, please don’t hesitate to reach out. We are always happy to help! 🤗