Best answer

I'm missing the customer name & email from the sample data with WooCommerce's Booking trigger.

  • 27 June 2023
  • 8 replies
  • 91 views

Hi, I’m trying to build a zap from WooCommerce Bookings to Zoom however in the test data it appears that it doesn’t pick up the customer first or last name nor their email. How can I get these fields added to the data pulled so it can then go across to the Zoom registration?

Thanks

icon

Best answer by ken.a 28 June 2023, 08:55

View original

8 replies

Userlevel 7
Badge +6

Hi there @cstcmyotherapy,

Welcome to the Community! 🎉

I did some digging into this, and it seems like the “Booking” trigger doesn’t return the customer’s information. This could be a great feature request for this trigger. I would suggest reaching out to our Support team to have them create a feature request on your behalf. You can reach our Support team here: https://zapier.com/app/get-help

In the meantime, adding a “Find Order” step after the trigger should return the customer’s information. Have you tried adding the “Find Order” step to see if it’ll return the customer information?

Please keep us posted! 😊

Thanks, ill

send it through to them. I have tried adding find order but now at the final step it’s saying validation failed. I haven’t had a chance to try and do out why yet but wondering if it’s because I can only use limited steps on the free plan

Userlevel 7
Badge +6

Hi @cstcmyotherapy,

Thanks for giving that a try!

Before we dive deeper, could you please send a full screenshot of the step where you’re getting the “Validation failed” error? Also, please ensure that the fields of the action is present in the screenshot. Here is an example screenshot of what I’m looking for:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

 

 

Userlevel 7
Badge +6

Hi @cstcmyotherapy,

Thanks for the screenshots.

Looking at the screenshots, it looks like there’s a “slash” before the email data mapped in the “Email” field in the “Create Meeting Registrant” action.

13a2d832739b6480682caa4afee6ea02.png
(view larger)

Could you please try removing the “\” in the “Email” field, and test the action step again? Also, please ensure that the email address mapped on the “Email” field is a valid email address.

Please keep us posted! 😊

Thanks, fixed that. Now it’s bringing up the multi-step zap which I’m not on a plan for

Userlevel 7
Badge +6

Hi @cstcmyotherapy,

Cool! I’m glad that worked!

However, I wanted to let you know that as a user on the free plan, you won't be able to publish a multi-step Zap. This limitation is due to the fact that multi-step Zaps are available only on certain subscription plans.

If you're interested, you can check out our pricing page at https://zapier.com/pricing to explore the different plan features and see which one best fits your needs.

If you have any other questions or need further assistance, feel free to ask. We're here to help! 😊

 

Reply