Best answer

I keep getting: failed to find event - Google Calendar - Searching Event based on ID in description field

  • 14 December 2023
  • 5 replies

Userlevel 1

hi there, first time posting here, just fyi.


What am i doing:

I am trying to set up a full 2-way sync between my Google Calendars (all of them) and a single Notion database.

How do i do it:

In order for this to work, i need unique identifiers on both ends, so when one side has a new or updated item, the other side can properly be checked for pre-existing items before one is created.


I use the ID Fields from both Notion and Google Calendar for this.

  • When an entry is created in Google Calendar, it will write its event ID into a property in Notion.
  • When an Entry is created in Notion, it will write its Page ID into the description field in the Google Calendar event.


Important side info, so nobody gets alarmed:

i am already preventing an endless loop, by filtering out all “Database Item updated” triggers from Notion, that have been last edited by the Zapier Bot, and not by me.



Now my problem:

Whenever i try to use the Find Event Step for Google Calendar in Zapier, i get :

“Failed to find an event in Google Calendar
Error from halted execution: Nothing could be found for the search.”

i am using the last digits from the Notion page ID, which was previously written into the event description.


Fixes i tried:


at first, i tried writing the unique URL from Notion into the description. Thtat didnt work.

It would have been convenient, since i could go to the Notion event in one klick with that, but since the search function seems to be very picky, i figured, lets not do that.


Then i read, that underscores can be a problem, so i removed those from the description field too


Next i used the Notion Page ID, but this string contains multiple “-”, which apparently are interpreted as “without” in the search field. so i used a formatter step to split the Notion page ID at every “-” and wrote only the last digits into the description. At this point, i have a string of letters and numbers in my Google Calendar event description, that should be easy to look up, but i still get the error that nothing was found.


Oh, and i have nothing else defined in the “Find Event” step, so no start or end time or anything else. Just the search field, with the output from my formatter step:




Best answer by Troy Tessalone 14 December 2023, 16:51

View original

5 replies

Userlevel 1

Update: Problem solved.

I just needed to fill the Fields “Ends Time After” and “Start Time Before”

(i used +1 year and -1 year respectively)

now this might seem obvious in hindsight, but these fields are NOT marked as required.

Zapier Team, if anyone reads this: please mark these fields in the “find Event” step as required. Or, if possible, remove this requirement.

I would love to be able to just look up Google Calendar events just by providing a Search phrase to look at the description and/or the title. best case, even seperately.

also, it would be amazing if i could also search for the Event ID of the Calendar events! That would save so much time and eliminate potential for errors.

Userlevel 7
Badge +14

Hi @AutomationAaron 

What about using this logic?

  • If the Notion Item does not have a GCal Event ID, then that means there is no corresponding GCal Event.
  • If the Notion Item does have a GCal Event ID, then that means there is a corresponding GCal Event.
    • You wouldn’t need to find a GCal Event, because you can use the GCal Event ID


Userlevel 1

@Troy Tessalone  yes, as you can probably tell i am pretty new to this.

I just set up a sync for my google Tasks, and realized i should do it like this.

I will do the same for my calendars, this will save me tons of tasks ;)

Thank you!


However, the point i made about the time horizons being required to find events in GCal, is still something worth looking at , i think.

Userlevel 7
Badge +14


Best to submit feedback and feature directly to Zapier via a ticket to Zapier Support:


P.S. I don’t work for Zapier.

Userlevel 1

I was having the same problem Aaron; your fix worked for me as well. Thanks!