Question

HubSpot error: Property value were not valid: [{"isValid":false,"message"

  • 20 April 2023
  • 3 replies
  • 169 views

Userlevel 2
Badge +1

I’m familiar with how the app requires the value to be in a specific format so the error HubSpot is providing is understandable but I’m also attempting to understand what the differences are that prevent it from being valid. Hopefully my explanation below makes sense. 

 

I have two list arrays that are the output from the 3rd step.

Contact Type List/Array
Practice Group List/Array
Contact Type property matching
Practice Group property matching

 

And above is the end result. Notice the contact type works and the practice group doesn’t. I checked the array to make sure all values are matching to the T, but still causes an error and I’m noticing the Practice Group list has commas for each item; perhaps treating it as a large string?

What makes this even weirder is I ran the zap again and it succeeded as I was writing this out. It’s like a kid that knows it’s in trouble so it straitens up. 

 


3 replies

Userlevel 4
Badge +6

Hi @Arment 

Welcome to the Community! I'm sorry you’re having trouble with your Zap.

I noticed that you're using an older version of HubSpot, and I'm wondering if that might be the case here.

Legacy features may still work as long as they're not yet deprecated. It only means that it is outdated and isn't recommended to be used since the newer features are now added.

Could you make a copy of the Zap, and in the copied version, try switching it to the latest version of HubSpot and see if it fixes the issue?

Userlevel 2
Badge +1

Thanks Brem, 

It’s working currently and had been working before. I’m not exactly sure what happened but we suspect it could have been the result of commas in HubSpot’s code values. If Zapier treats commas as a delimiter in list items and there are commas within those list items then that can cause unforeseen implications we may have witnessed. I’m not sure if updating HubSpot application would fix that but if trouble arises again that can be the next step. 

Userlevel 7
Badge +9

Thanks for keeping us in the loop, @Arment! Glad to hear the zap straightened its act up! 

Hmm, you may be onto something with the commas though. Keep us posted if you run into this again though! ⚡️

Reply