Best answer

GPT error "It appears that the required Zapier AI Action, "XXX," is not currently available in your Zapier account.

  • 20 February 2024
  • 7 replies
  • 159 views

I am having issues with my custom GPT saying I have no AI Actions available when I do. I have one AI Action that worked a couple of times and now I keep getting a GPT error saying there are no actions available.

Error message

 

 

My AI Action

 

 

I used the Zapier AI Actions: Live Demo to test my AI Action and it succeeded. So I know my AI Action is configured correctly.

 

 

Not sure what’s going on and looking for guidance.

icon

Best answer by cryptorunr 22 February 2024, 18:30

View original

7 replies

Userlevel 7
Badge +11

Welcome to the Community, @cryptorunr!

Sorry to hear of the troubles here! Hmm, it’s odd that it was working previously and then stopped suddenly. Presumably no changes had been made to the set up of the AI Action between when it was working and when it stopped working, is that correct?

Can you please share a screenshot showing the details that appear when you click on [debug] Response received to expand it:

3812539b9404589188fa71f9d7d85b76.png

That’ll help us to see exactly what error message was received by the GPT when attempting to run the AI Action. I’m thinking that there may be some clue there to help indicate what the cause of the issue was.

Thanks, I look forward to your reply! 

Here is the output of the [debug]Response Received

 

 

Userlevel 7
Badge +11

That’s very strange. With a status code of “200” that would indicate that it was successful but it didn’t return any results for the search. 

When you tested in the Live Demo section did it return a result for the search. It would look something like this:
1f0698d23c19ad084316fa9160c71891.png

Or were no results listed in the Results section there?

If none were listed then it may be that there’s something wrong with the setup of the search action. In which case can you share a screenshot showing the set up of that Get Friday Stories AI Action, so we can double-check the set up there?

Also, can you confirm that all the steps outlined here were followed in setting up the instructions for the GPT? Just want to make sure nothing was missed on that side that might have caused an issue with the GPT being able to run the AI action.

Keen to get to the bottom of this so will keep an eye out for your response! 🙂

So I’ve reviewed my settings dozens of times and tried lots of different things and finally found one way to get it to work.

When I run my GPT and get the “not currently available in your Zapier account” error, I click on the GPT Privacy Settings, log out, and the log in. This somehow fixes the problem and allows the AI Action to be seen and executed.

 

Userlevel 7
Badge +11

YAY! That’s fantastic news, @cryptorunr! 🙌 And thank you so much for sharing the solution you found here. This will greatly help other folks with similar issues that come across this thread, so it’s much appreciated! 🤗

If you run into any further issues or questions please do reach out in the Community again, we’d love to hear from you! 

no work!!!!help me!!!

Userlevel 7
Badge +11

I’m so sorry to hear you’re running into some trouble here @nanae

Can you please share some further details as to what’s not working?

Is it that you tried the solution outlined in cryptorunr’s last post and it didn’t work? If not, can you give that a try and let us know if that resolves it?

If you’ve given that a try and it doesn’t work can you share screenshots of the setup of the AI Action? And confirm whether you’re seeing this same [debug] Response result status code?: 
569a56db36c7587f950070c0e9f39aa3.png

Looking forward to hearing from you on this!

Reply