Question

Google Calendar all-day events not transferring to Bigin CRM

  • 12 February 2024
  • 9 replies
  • 37 views

Hey everyone, 

I’m trying to transfer existing events from my Google Calendar to Bigin. The tests that I have done in this zap have worked, but the existing events in the Google Calendar always come back with the same error: Required field "From" (datetime::Start_DateTime) is missing. Required field "To" (datetime::End_DateTime) is missing.

When looking at the data coming in from the Calendar, I can see that the Start Time and End Time are not present, which is probably why that field is greyed out in the transferring data section, causing them to fail. 

Is this correct? If so, what can I do to fix this? 

Screenshots are attached. 


9 replies

Userlevel 7
Badge +14

Hi @dantesdavid 

For us to have more context, post screenshots with how your Zap steps are configured.

Thanks for the quick response. I have uploaded various screenshots. 

Userlevel 7
Badge +14

@dantesdavid 

Most of the attachments did not upload.

 

That’s odd. Let me try uploading along with a comment. 

Userlevel 7
Badge +14

@dantesdavid 

Check the field descriptions for how the date must be formatted.

You can use Zap steps: Formatter > Date & Time > Format

 

Running the test has always worked. It’s the existing calendar events, which are formatted the same way, that are failing with an error. I will attach screenshots of this. 

Userlevel 7
Badge +6

Hi there @dantesdavid,

I’m jumping in to see if I can help!

Whenever you see those {{...}} curly braces around entries in the Data In of an action, this means that there is a field mapped there in the Zap Editor, but when the Zap ran live this data was not sent from a previous step.

Could you please try using the “Start Date” and “End Date” instead of the “Event Begins” and “Event Ends” data?

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Hello @ken.a

I don’t see any curly brackets in my data., Like I’ve said already, the zap works. It’s the existing data in my Google Calendar which is coming into Zapier without dates that’s the problem. It runs new zaps without error. All I need is to be able to run these existing events so that I can continue on with life...

Userlevel 7
Badge +6

Hi @dantesdavid,

I appreciate your follow up here.

I believe this is due to the mapped “Event Begins” and “Event Ends” sometimes Google Calendar doesn’t return those data when the Zap runs. Could you please try remapping that to “Start Date” and “End Date” instead?

I really appreciate your patience and understanding.

Reply