Best answer New Video Added Not updating to correct field Airtable

  • 23 December 2022
  • 5 replies

Userlevel 1

Not sure if this is a air-table or zaiper question hopefully someone can explain to me. 

This is what im trying to do:

  1. Uploaded video To where the name of the video is the same as a Unique ID in airtable ( called Asset ID ) in Airtable 
  2. search for a field ( Video Edit ) 
  3. Input text or link  to inform that video has been uploaded 

I have tried to find the record using a search function and my zap looks ok but when i run it it does not update to the correct field.


when i test the last part of my zap ( input text ) it will only place it in the first record and not the one attaching the unique ID 


i have tried the following SEARCH functions also FIND 

SEARCH(({Asset ID}))!={Edit}

SEARCH(({Asset ID})) = {Edit}


not sure if it is that or when i go to set up my action in the RECORD section i am picking the wrong dropdown.


i thought it may be “custom” “zap search was found” but didnt work , and i have also tried multiple other options 


any input would be great :) 


Happy Holidays 





Best answer by Troy Tessalone 23 December 2022, 22:48

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Rlaurence83 

Good question.

Please post detailed screenshots with how your Zap steps are configured in order for us to have context.

Please also post screenshots from Airtable for the related fields.

Userlevel 1

Thanks for the reply Troy appreciate it :) . See attached screen shots from both Airtable & Zaiper.


Userlevel 7
Badge +14


The Search formula is not correct as there are no mapped variables from the Zap trigger step.

Make sure to review the help article in the field description:


In step 3, you need to map the Record ID from step 2.




Userlevel 7
Badge +9

Hey there, @Rlaurence83! I wanted to stop by and see how you were getting along with this?

Were you able to map the Record ID’s from @Troy Tessalone’s reply? Keep us posted! 🤗

Userlevel 1

yeah i was successful :) i still dont know the logic behind it but its working :) now to figure out how to “store” chnages in storgae then apply them to each record ID