Question

Formatter by Zapier Issue: Split Text Not Mapping as Separate Fields

  • 7 September 2023
  • 3 replies
  • 27 views

Hello Zapier Community,

I hope someone can help me out with an issue I've been facing. I've been using the Formatter by Zapier to split text, and while it does split the text correctly, I'm having trouble using the split text as separate fields in my flow.

Here's a brief overview of what I'm trying to achieve:

  1. I take an input string and split it using the Formatter.
  2. I want to use each of the split parts as separate fields in the subsequent steps of my flow.

However, when I try to map these split parts in my next steps, they don't appear as individual fields. I'm not sure if I'm missing a step or if there's a configuration setting that I've overlooked.

Has anyone else faced this issue or have any suggestions on how to resolve it? Any help would be greatly appreciated!

Thanks in advance!

 


3 replies

Hey Troy,

 

Thanks for your answer. 

The way I have set it up is: 

I generate 4 images with OpenAI. The output is 4 urls, separated by a “,”. I use the text splitter to seperate the URL’s. The end goal is to display them in an email with <HTML>.

 

The way text splitter is setup:

The output looks perfect:
 

But whenever I want to insert them in the code, I just get the option of one output field. ‘Output item 1’. As you can see, the “,” is still there as if the text splitter shows the input in stead of the output.

 

Any idea?

Userlevel 7
Badge +14

@Maxim 

Here’s the issue…

The Input value is an array of items, rather than a string of text.

Try adding this Zap action: Formatter > Utilities > Line Items to Text

Then use the output of that Formatter step in the Zap action: Formatter > Text > Split

 

Userlevel 7
Badge +14

Hi @Maxim 

Good question.

Please post screenshots with how your Formatter step is configured to help give us more context.

Reply